How to display only the tringle Mesh and disable the surface mesh, curves and points?

display
mesh

#1

I’m converting surface to mesh using the “_Mesh” tool. I wish to view only the mesh and take out the surface from my perspective window. I wish to create a Display Option for showing only the “Mesh” preview while converting the surface into mesh [ using the ]. How can I display only the triangles Mesh with no lines for inspecting the tangent and disable, hide from view the surface mesh, curves and points?


#2

Hi. Create a button, and add this simple macro:

_SelMesh
_Invert
_Hide


#3

Thanks, but is NOT what I’m looking for. Your answer is perfect to inspect the mesh when is finish the conversion from surface to mesh and you want to inspect the mesh hiding all the rest.

When I’m creating a mesh form a surface using the _Mesh tool, the surface overlap the triangles of the new mesh preview and is not possible to inspect it in the process of selecting the density or values. Because the new mesh is under the surface.

I need to create a new Display Mode and a custom button.

What I’m looking for is to inspect the mesh in the process of creating the mesh from a surface. So I need to select the surface that I whant to convert, then press a custom button that change my display settings to a new custom one “Mesh inspector” and later triggers _Mesh. I need to create first a new “Display Mode” that hides all the rest ans show only the mesh.


#4

@AlanMattano,

There is no easy way to accomplish what you want currently. The only workaround is to switch to a Wireframe viewport display mode, in that display mode disable “Surface Isocurves” and “Surface Edges” then select your object and type _ToggleRenderMesh in the commandline. This way you see the mesh only. Now navigate to

Document Properties > Mesh

and adjust your mesh density from there as shown in the image below:

After changing the mesh settings, click the “Preview” button…I know this is not as comfortable since you’re not in the _Mesh command and you cannot adjust the camera position while the dialog is open (unless you’re using a SpaceMouse). The problem here is that if a surface or polysurface is selected, Rhino is drawing the selection wireframe even when you’ve chosen not to draw it in the display mode.

c.


(Pascal Golay) #5

Hi Alan - there is a bug item about this very problem - it is not public for some reason, so I did not add a link here but I added a comment to it about this thread.

-Pascal