How to display decimal inch above imperial inch for a dimension?


I need to have the decimal inch above the imperial inch.
I am forever without space to have the row option.

here its gone across into another layout window in my image.

how is this done ?

Also how to make the figures appear to left of the arrows is something else I sometimes need. ?
Decimal above imperial.3dm (35.6 KB)


I don’t think this is possible in R7, let alone R5.

Edit: As Wim points out below, it certainly can be done in R7. Apologies for the misleading post.

Hi Steve -

In Rhino 7, there’s the Alternate units below option:

As was answered in one of your other threads the other day, you can turn on the control points and move the text.

V7 then for the above and below, though I need to get this job done then turn win7 into win10.

Wim, I turn on control points, I have a pair at either end, they move the location of the dimension measured distance, the one in the middle makes arrows become inward pointing on narrow objects if moved sideways. BUT nothing makes the text shift to left of centre.

Can someone show me this happening perhaps.


It’s impossible for me to tell what settings you have for those dimensions - it’d be a lot easier, as always, if you could just post that single dimension in a 3dm file.
At any rate:
2022-05-25 v5-Dim


a V5 3dm attached.
lets say I need the 1 inch digits off to left of the left arrow.

where in rhino is that natural , outside etc interface you are using ?

If you are referring to the file that is attached in your first post, there is no 1" dimension in that. The picture doesn’t reflect the contents of that file.

I added a dimension using the same style as the radial dimension in that file and had no problem moving the value to the left:


That’s in the Properties panel when you select a dimension.

Note that, apparently, when using alternate units, you need to make sure that the dimension value sits slightly higher than the original position in order to have the arrows be moved to the inside. That appears to be because of the square brackets that extend below the base line of the numbers.

Also note that, if all else fails, you can always explode a dimension and move any of its parts anywhere you want.

In Rhino 7 you can move the “1” dimension text to the left with the “Fit text” property:

You use the “Left” option to move it unequivocally or “Hint left” to make it move to the left only when it won’t fit inside the lines.

Note that, separately, you can override the inside/outside positioning of the arrowheads.