What is best way of displaying dims and working in inches-decimal when currently mm?

I have measurements of an item, some in mm and some in decimal inches.

As I work I wish to enter both mm and inches and opt between dims in inches and in mm at different times during construction.

  1. having started out with a mm project, how do I go over to entering inches and seeing inches rather than mm displayed in dimensions but keep my nicely proportioned dims text relative to model size as the mm dims were ?

I wish to easily switch between mm and inches decimal as I work and see the dimensions go from e.g 16.2 to 0.75 (inch) then back again to 16.2 (mm).

2). Also if cylinder 16.2mm dia and length 0.32inch. If my units is mm for the project, can I enter both into command line ?

3). Furthermore if model units started life as mm, so I have a minor grid line 1mm and major lines every 10mm and dims displaying in mm, how do I make the dims show decimal inches and the grid now have major lines every inch but without the dimensions growing massively and obscuring the model ?

Is it necessary to alter model units and go scaling yes ? I end up with massive dims and cant see the object !

I dont want to be editing dims to be able to see my model, then when I switch to mm, not see the dims text because its shrunk massively.

In properties there is Units displaying mm

also model and also layout all displaying mm.

Never sure which one to change.


I’ve never mixed up imperial and metric in one drawing so not sure either, how to work the combination properly but here is an attempt.

I believe you need to choose either an imperial or a metric drawing and make conversions while you work. At the command line you could use a multiplication or division factor to arrive at ins or mm, for example;

in an inch drawing, if you wish to draw a line, for example, at 1mm long then if you type 1/25.4 , the line length will be 0.03937in, i.e. 1mm.

For alternate dimensions - in an inch drawing, you can create a new mm dimstyle - (defaults to 1:10 for some reason) and change scale to 1:0.03937 and length factor to 25.4.

The selected dimensions can be efficiently toggled between the 2 dimstyles via the properties dialog

To change your grid use the dashed version of the command ‘-Grid’ or if you want a quick way to toggle back and forth set up a new button with inch on right click and mm on the other,
i.e. Paste the 1st set below for inch,( the settings in your particular example) and the second for an equivalent metric - adjust settings to suit the drawing;

! _NoEcho _-Grid

! _NoEcho _-Grid

During modeling coordinates, lengths, etc can be entered with units different than what is currently set as the working units. Just append the appropriate suffix. A coordinate could be entered as 1.2in,25mm,0.3ft if desired. Rhino automatically converts the input to the working units.

From Rhino help

Distance Units

Use any of the Rhino unit measurements including fractions. You can mix fractional and decimal input.





















Feet and Inches
























Printer point

Printer pica

Nautical mile

Astronomical unit



Hi, Thanks,
I need to study this and experiment so that is comes natural.

A command to run that allows toggling of entry of inches dims or values in a mm project and which makes the behind the scenes changes shown here would be useful ! To have the inch dimension such as 1 inch show as 25.4 [1] is a good option.
Sort of basic stuff I had hoped to see by now.


what’s the basic stuff you expected by now exactly?
you have an app that you can enter values in almost ANY known unit, and you expect it to automatically read your mind and spit out the dimension you place in the unit you happen to be thinking of at that particular moment? seriously?


I didnt say I was to type a value and expect it to mind read me and know if that was inches or mm.
if I did show me where ?
I simply said it would be nice to have the ability to enter a command, select a unit of measurement, then type a value and Rhino converts it to the project units and adds it to the dim as 25.4[1]

taking this from what I read above in the thread.

The above seems a bit involved, but I will memorise it, just saying that a command that does what is involved there would be good, an easy transition between inches and mm I call basic, maybe its advanced and beyond coding.


Well, it does work as you say, doesn’t it?
You go to DocumentProperties (for macroing this, -DocumentProperties), then to units, Model Units > select a unit of measurement.

As for the dimensioning, you can define you dimension style to have Alternate text with, e.g. [inch] like you indicate.

This is pretty standard in other CAD packages. Dual dimensions is very handy. Would like to see Rhino be a little more CAD-like.

Is this what you are referring to?

Steve, now I think you are talking about two different things.

[quote=“Steve1, post:6, topic:18583”]
it would be nice to have the ability to enter a command, select a unit of measurement, then type a value and Rhino converts it to the project units
[/quote] Rhino already does this seamlessly. Not sure if this is clear to you yet or not, forgive me if it is. Doesn’t matter what your doc units are set at, you can enter a command, and type a value with any other unit and Rhino will do the right thing.
The last part of that sentence makes it a different thing:

[quote=“Steve1, post:6, topic:18583”]
adds it to the dim as 25.4[1]
[/quote] and is addressed by @wim with the alternate text option in dimension properties. At least I think that is what you mean.

Sorry about my snark the other day. It was late. I was tired.


So if I am set to mm as I normally have projects set to, and I type 1, it will convert to 25.4mm ?
How does it know I wasnt typing 1mm ? I trust there is a suffix to add, something like " for inches ?

How does one get the 25.4 [1], I cant see how to do this in properties for Dimensions.

Ok on snark, forgiven :smile:

If you need a different unit than the one your document is set at, you need to include that after the value. So if working in mm, and want 1", you type in 1". Or 1cm, 1m, 1’ etc.

for getting dual dimensions, see pic below. You need the alternate text box checked.
But @BrianM already showed this above.

From my reply to this thread a week ago:

Dimensions entered without a unit suffix appended are interpreted as the default units.

Scroll up in the thread to see the complete list of units and associated suffixes available, or use Help in Rhino.

Hi David,
Sort of knowing I had read that recently I didnt think to scroll up.

Miles, I never think to use Rhino on such a scale :smile:
Feet and Inches, now to enter a value such as 3ft 4.5 inches would be good, I shall read up on how to do so. Your list shows such is possible.

I have searched for the help on such and cannot find it, tried various words that might latch onto it, maybe just missed the key word. Feet I thought might find it, but didnt. I also tried ‘entering units’ as well as unit entry , inches, just in case it found such in the article.

Anyone know of the location to find out more about how to enter something like 3ft 4.5 inches or 39 7/8 inches etc ?


Any distance can be entered in fractional form rather than decimal form. 3-3/8 is interpreted as 3.375 units.

Scroll up in this thread to my post of a week ago. How to enter feet, inches and fractions of inches is covered in the list I copied from Rhino help. Also found in Rhino help for “units”, select Model Units Document Properties and then scroll down to Distance Units for the info I posted above.

I’m sure @margaret will be interested to catch this.

Hi, found it, bit more buried than I thought.

1’2.2(") would be how to enter 1 feet 2.2 inches it would seem

so I choose line tool, type 0,0 for start point and hit enter, then type R1’2.2("),0 and hit enter and no second point ocurs, nothing happens, try again with 0’ this time, still nothing.

have I misinterpreted 1’2.2(") for 1ft 2.2inches ?


No parenthesis used! The parenthesis in the list above mean what is in the parenthesis is optional.

So 1 foot 2.2 inches could be entered 1’2.2" or 1’2.2

Hi, ok…


No, it can’t be entered as 1’2.2
1’2-2/10 or 1’2.2" will work though.