How to disable rounding decimals


I am having an issue of all of my dimensions being rounded to 2 decimal places. Even after ensuring that I have more than 2 decimal places available, I can’t get it to give me a precise dimension. To test it, I even made a line that was 1.9375 and used linear dimension. It turned up as 1.94. I’m not worried that it’s changing dimensions but I need to know the precise number so that I can do some math.

Thanks in advance.

Maybe defining it under Options

Hi Griffin - for dimensions, as opposed to command line display, precision is controlled in the dimension style settings - e.g.:

Is that what you needed?


I think you have confused the decimal number in the Units display, with the named Annotation style setting your dimensions use.

The former controls unit display in the Rhino application interface, while the latter controls how dimensions appear.