How to correct geometry display problem?

Greetings to all,

I have a question regarding what appears to be a display discrepancy, but maybe not?

So I am dealing with some planar shapes, which I then thicken:

notice that here meshing is disabled:

with meshing enabled, the geometries look like this:

so…

meshing disabled shows the quality I want:

meshing enabled doesn’t:

After baking (regardless of meshing disabled or enabled), I get this,
where regions marked with an ‘x’ are what I don’t want:

In fact, I don’t even need to thicken for the bug to show up:

boundary surfaces prior to thickening are a result of several curve operations (pulling, pinching, splitting, joining again, etc.) - areas with super tight control points were my initial suspicion - once I simplify all curves, point duplication is resolved, yet I continue to get a remnant of the bug still:

Why is that or which settings should I edit to avoid this?

I appreciate your help and thank you in advance for any suggestion.

Here’s a sample:
ribexample.gh (155.2 KB)

preview
?

thanks @Joseph_Oster! I attempted baking with all preview modes - I don’t think that does it - did you try baking it?

I didn’t look at the model at all, just pointing out a common issue. Previews can look weird at less than “High Quality”. OK, looking at the model now… Looks pretty good to me. I baked the output and looked VERY CAREFULLY to find one section that exhibits anomalous behavior like you describe. I don’t know what’s causing that as I now have GH disabled completely. Your offset distance (0.01 and -0.01) is very small, don’t know if that’s a factor?

anomaly

Baking the curves alone, before and after Simplify, shows them to have MANY control points and a few discontinuities that happen to be near these anomalies.

The problem appears to diminish (vanish?) if you Rebuild the curve using a fraction of the original control points (~1/3rd), but then you don’t have the same “ribs”.

ribexample_2019Jun26a.gh (157.7 KB)
ribexample_2019Jun26a

There has been a lot posted here (and the old GH forum) on thickening surfaces.

1 Like

Thanks for taking a look Joseph. I agree that rebuilding ‘corrects’ the issue but yes, it creates new (undesired) shapes.

I will play with the offset distance a bit more or with units - I guess at this point I am testing some limit here.

I believe it’s a Rhino’s Render mesh quality problem.
Switch to “Custom” quality fr “Jagged and faster” in rhino option would help to resolve the problem.
(Beware, it’s slow.)



thank you Kim :pray:t6: looking into this

After that, you can choose “Document Quality” in GH, or use “Custom Quality” at the beginning.

@HS_Kim has the answer but oddly, the problem mostly vanishes even when you push the slider in my model to ‘1.0’, using the same number of control points as the original curves and looking very similar. Good luck. What are these “ribs”, anyway?

Probably because if you have a heigher density CP count on your profile curves, more chance to get heigher density render mesh…