How to close or disable grasshopper player preview after use?

Grasshopper player = the best new feature of Rhino 7. But how how do you turn off the grasshopper preview-display after use?

Hi -

Could you describe that a bit more and perhaps add a screenshot (or better, the *.gh file)? There shouldn’t be any remaining Grasshopper previews after the player is done with it.
-wim

offset-Mitered_Surface_from-Curve.gh (16.5 KB)


Thanks for looking into it. After every use the grasshopper preview is left behind.

Hi -
This is what it looks like when I run this on a single rectangle with a single offset value and make sure the command line no longer asks for input:

Have you closed the Grasshopper file and exited Grasshopper when you use the GrasshopperPlayer command?
-wim

The GH player display issue has been resolved with the Rhino 7 SR6 Release Candidate 2 update.

1 Like

This still seems to be a problem. Any preview generated during the grasshopper script persists in the rhino viewport after the grasshopper script has completed. I’ve tried 7.7 and 7.8 release candidate.

Hi - please post your file…
-wim

Here it is. Oddly I found out on a new install on a laptop this doesn’t seem to occur. Grasshopper is closed when this occurs. If I never open grasshopper during a rhino session it does not occur.

test.gh (2.9 KB)

@Wim, did you ever get to the bottom of this one?

I am having a similar issue that seems to be related: No file is open in Grashopper, I run GrasshopperPlayer and the solution works as expected, but afterwards, the GH solution keeps on solving, even after I finish/cancel the GrasshopperPlayer command and draw other Rhino geometry. If I make a change in Rhino that has an effect on the GH solution (for example, adding a curve to the C::TOPO-MINR layer), it recalculates without me running GrasshopperPlayer. The only solution I’ve found is to restart Rhino.

This seems to be an issue w/ GrasshopperPlayer and not my definitions: when I run the definition by itself, everything runs fine. Whether or not Grasshopper is open does not seem to make a difference.

Strangely, I was having the persistent preview issue (described by Joshude and Datedvm above) with the Lamp sample files a couple days ago, but am no longer able to replicate the issue.

My files are attached. Manipulate curves on C::TOPO-MINR to test the recalculation.

Any thoughts? Thanks for any help you can provide. GHPlayer seems VERY promising, but this seems like a pretty big obstacle to implementation in everyday workflows.

EDIT: I discovered that GrasshopperPlayer works as expected (no running in background / persistent preview) until Grasshopper is opened. The definition doesn’t have to be opened, just Grasshopper. After GH is opened, the problems start. They can be fixed by disabling the solver:

image

adnFG_Mesh.gh (38.9 KB)
Hoskins_CD_Purged.3dm (16.0 MB)

I’m having the same issues. But the solution with the solver doesn’t help me. Only not opening Grasshopper itself. But I’m working on my Tool… that’s not an option.

Anyone?