Grashopper still active after closing

in rhino 5, when closing the grasshopper window, all grasshopper objects would disappear, which was quite handy. (if gh-objects should still be displayed one could just minimize the window)
rhino 6 always shows all grasshopper objects even after closing the window.
can the old behaviour be reestablished or am i missing an option or command?

Hi - I’m not seeing that behavior here.
Is this happening with a specific definition?

thanks for the hint!
checked some other files and yes, it only happens with specific rhino/grasshopper combinations. found the following: when using a custom preview component in grasshopper and displaying it in a rhino viewport with rendered display mode the “glitch” discribed above would happen. i guess this is not intentional, is it?

I wouldn’t think so - I’ll ask if this can be tuned up…
(happens with the Raytraced display mode as well)

@brt1 - filed as RH-51116 .

You can right click on the preview component and untick ‘render’. Preview and render now seem to have separately controls.

unticking “render” makes it invisible in rendered, shaded and raytraced viewport. (even if preview is on)
when selecting wireframe, technical or others, it becomes visible.

Could you please upload the simplest gh file you can that shows this issue?

Have a look at this thread

i use a simple sphere (no extra settings) and a preview (no custom material or color).
preview_render.gh (6.0 KB)

upper viewport is rendered, lower viewport is wireframe
screenshot 1: grasshopper on, render ticked:

screenshot 2: grasshopper on, render unticked:

screenshot 3: grasshopper off, render ticked:

screenshot 4: grasshopper off, render unticked: