How to change pdf print setup template?

I searched for how to change the default setting in the print setup for pdf but no luck finding any hints.
Every time I start Rhino and want to print a pdf, it has reversed back to showing inch as scale value. Is it possible to change that to mm in the setting for the template? Its just a bit annoying since I dont work with inches at all…Screendump


Have really tried to find some info, but no luck so any info would be much appreciated!

Hi Fred
And thanks for your answer, but I already been there and tried to find some solution there, but I cant find it! I also checked if it is some setting in the pdf properties, but it is already set to mm. I dont think it exist in the metric properties of the Rhino template, but please prove me wrong!

For example, if you want Rhino to use Millimeters as default units, use the New command to open the template you want to change, change the units to Millimeters and use the SaveAsTemplate command to overwrite the changes to the template.

It is in the “Print” command it says “inch” (see the first post,the attached image), not in the document template. In the print window under “View and Output Scale” and under “Scale” it states On Paper = In Model, and the value “On Paper” always reverts to “Inch”…

Unless you change it here:

Or prior to printing:

I use the mm document already

And I was hoping not to being force to always change it from Inch, since I dont use inches at all!
I just want millimeters…

@pascal Do you have any idea about this? Or maybe @Helvetosaur ?

:face_with_raised_eyebrow: ? SaveAsTemplate

@Per I’m very sorry, my error. Set/save as template does NOT solve the paper units=inches problem.

Sorry that I haven’t seen your post until now!
I am very happy for your effort but as you say it does not solve the issue.
If anyone could pitch in I would be very thankful because at times I sit and export a lot of drawings to pdf (for ex) and its quite tedious to change from inch to mm every time I reopen Rhino.
I am a metric kind of guy :slight_smile:

1 Like

@stevebaer Bump ?

I created a bug tracking issue for this at

1 Like

@stevebaer Hi and thank you!
Hope that it will be an easy solved task!
And a Merry Christmas and a goood new year to all here at this fantastic forum!

1 Like

RH-56373 is fixed in the latest WIP

1 Like

Hi Brian
And thanks for your effort! But why is it not implemented in Rhino V6? And will it not be at all?

I believe this was mislabeled. I fixed this in the V6 codestream so the fix is in the V6 SR release candidate and V7 WIP

Sorry, but still reverts to inch, when reopen Rhino v6! Maybe I do something wrong?!
But checked and its working in WIP!
Screendump1 Screendump2

I have the same issue, but for all printing not just pdf, our projects are in mm, but the printer setup always opens on inch to millimeter.

Also the Headings always open on closed as in pic, In Rhino 5 they stayed open , the ones I used last. I always use the scale, and visibility options so have to open them each time and change to mm.

Try to use custom PDF software in order to configure printing options. For example, I use one from Movavi: I saw another thread somewhere on the forum with many proposals and alternatives, but I’m sticking with it for now as it works.