How stable is Rhino supposed to be? Crashing/Freezing


I often encounter Rhino freezing, not responding, and crashing. Sometimes when dealing with complex models, sometimes with simple models. Even loading files results in (Not Responding) in the app title.

This behaviour is encountered on both my PC and Laptop. They are specced sufficiently (Blender of C4D handle the same files smoothly).

Could this be due to the Educational Lab Licence?

Edit: copying / cutting selections also cause the program to Not respond temporarily.

Normally this kind of random freeze is indicative of a video card/driver problem. Please run SystemInfo in Rhino and copy/paste the results here.

No, normally this is not a problem.

hino 7 SR26 2023-1-9 (Rhino 7, 7.26.23009.07001, Git hash:master @ 92abcf7c453c78a236526390d91d0ac1f6779143)
License type: Educational Lab License, build 2023-01-09
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 960 (NVidia) Memory: 4GB, Driver date: 11-13-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 526.98
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-13-2022
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I guess the first thing I would try is temporarily disabling the V-Ray plug-in and see if the crashing stops.

vray is, sadly, a common crasher of rhino.

May be worth grabbing an updated Nvidia driver and checking out this article for how to set it up. (works for desktops too)

I have disabled V-ray and still, the problem persists.
Will check the Nvidia drive as Kyle suggests.

Cutting this simple closed solid takes 10 seconds…

Well, the 960 is a bit old… wondering how good the driver support is for that.

You might try moving the following slider one or two notches to the left and/or unchecking the “GPU tessellation” box on the following page and see if the crashes stop: Options>View>OpenGL


The Aniosotropic filtering is high?
(Oddly, it’s usually 2x, 4x, 8x. Rhino has a funny way of reporting it.)

Unless you are doing long hallways, or close-to-far outdoor scenery, aniosotropic filtering probably can be lowered to say, 2x, or even disabled. On lower-spec systems, Aniosotropic filtering hits your GPU hard, and it’s not needed for Ghosted previews, nor final rendering. Aniosotropic filtering is an advanced texture-mapping technique beyond Mipmapping, that reduces artifacts in distant, angled objects, whilst keeping the textures sharp.

You have 4X Antialising, you might be able to lower that, as long as it’s not too jaggie-looking. If you have a 4k monitor, then you shouldn’t need to run much antialiasing.

You can special-case Rhino in the nVidia panel, and go though the settings, making sure they are what you want.

Also, in Windows Laptops, Microsoft replaced the Optimus system for selecting GPUs, likely so they can blockchain mine in the background. Anyway, the desired GPU must be set in both the nVidia panel AND the Windows Setting GPU panel. From the settings menu, you can type GPU in the box to find it, then set the preferred GPU. I recommend doing it in both. Both later-patched Windows 10, and 11 have a setting for this.

Also, you might check the computer and nVidia power settings, to see if they are appropriate. Also, later nVidia drivers have a low-latency mode. Lower the pre-rendered frames to as low as they will go.

I am curious, how are you cutting what you are working on?
Is the slowness you are seeing, all the time, or only while doing certain operations?

Also noting: if you are trying to do a Boolean subtraction for (poly)surfaces that have barely intersecting or self-intersecting faces, that might be an issue. Rhino usually does subtractions pretty well, though. An example of that is like trying to subtract from a large sphere, one that is only very slightly smaller, nearly overlapping. Another example of a difficult Boolean is to take 2 rectangle boxes, make them very long, tilt one a fraction of a degree, immerse it into the other box, and try subtracting the nearly asymptotic situation.

Generally, I suspect that the higher your tolerances, the longer the Boolean will take, and the more complex the result will be.

Also, if say, a vertex on a box has been tweaked, and the surface is no longer flat, then it might then create a self-intersecting object when another object just skims it. If you move a single vertex on a box in any direction, the surface is no longer flat.

[BTW, I reversed engineered a machine using a Lenovo X220, with a Intel Integrated (cough) GPU (which is not even feature-complete), though it’s not recommended.]