How can I orient a layout to my saved Cplane?


#1

Hei! i have a saved C-plane in my drawing. I am making a layout and I don’t find the way to orient the view to this Cplane, it is always oriented to world coordinates. Maybe it is simple but I don’t know how to do it. Any help? Thank you very much in advance.


(Pascal Golay) #3

Hi Monica- in the layout, activate (double-click) a detail, set the Cplane you like as the active CPlane in that detail and then run the Plan command- does that do what you need?

-Pascal


#4

That’s what I thought, but I do that and it doesn’t work. Looks like I cannot set active my Cplane - I select it but the world coordinates still appear.


(Pascal Golay) #5

Hi Monica- see if this file has what you are looking for-

CPlaneView.3dm (45.8 KB)

Also, to make a saved CPlane active, you can double-click on it in the NamedCPlanes panel.

-Pascal


#6

Yes. But I can’t manage to do it. It looks like I can’t set my cplane active.

What I do:
Double click on the detail. Select saved Cplane. Clic on the icon which (normally) turns yellow. Nothing happens. If I set view “top of Cplane” it just remains the same. This is the file - simplified .shaadie example.3dm (1.2 MB)

And now for some reason I managed to rotate the layout cplane and cannot rotate it back. What am I doing wrong? Thanks for your patiente anyway.


(Pascal Golay) #7

Hi Monica- try -

Open your file, make the detail active, Open NamedCPlanes and doubleclick on the named plane. Click back in the detail and run Plan.

?

-Pascal


#8

In order for this to work as Pascal describes for details, under Rhino Options -> Modeling Aids -> Construction planes needs to be set to Standard Construction planes.

I would love to see details ignore the universal construction planes. It has been wished before, but here is another nudge :stuck_out_tongue_winking_eye:


#9

That was it.
Once I change that in options it all started to work. I was doing as Pascal said from the beginning with no result!
Thank you both for your help!!