Help with hairy and broken curves in Rhino 7 on Mac

For some strange reason (most likely something I must have done and forgotten) all of the curves/edges in my models are acting weird and have “hairs” projecting out from them (see screenshots). This happens only in Wireframe, Shaded, Ghosted, and X-Ray view modes. The direction in which these hairs project out appears to be view-dependent. When I select an object, the associated hairs change color into a gradation of colors from yellow (close to the curve to magenta far from the curve). When I zoom in on an object the “hairs” disappear. In addition to the hairs, some of the curves appear broken up or missing sections when in the above view modes (although I also just realized in parallel projection mode the curves are broken up regardless of what view mode I am in).

Please embarrass me and let me know what I must have turned on and forgotten!

BTW: I am running Rhino 7 (7.11.21285.13002, 2021-10-12) on Mac OS 11.6.


Hi Kam - Does this happen with any file? What happens if you restore these display modes to defaults, in Preferences > Display modes page?


Hi Pascal,
Thanks for the response. This appears to happen with any file and restoring defaults in the Display Mode preferences does not get rid of it. However, every time I clicked on “Restore Defaults” the “hairs” changed slightly (see screenshots).

Do you have a clipping plane in your model? We’ve seen this driver bug with clipping planes on Mac before

Thanks for the response Steve. So, I put my machine to sleep last night after responding to Pascal and I just now switched back to Rhino to verify whether I had a clipping plane (which I don’t). I spent the morning doing all sorts of other tasks (email, Word, Zoom, etc.) and when I switched back to Rhino (which was still running from last night) just now the “hairs” and broken curves were gone! The preferences window was still open from when I restored the Display Mode defaults several times without success.

Not sure what to make of this, but I am happy to have normal Rhino behavior back.

The weirdness continues…

Tonight I wanted to import a very large mesh file (in IGES format - don’t ask!) into a new Rhino model and as soon as the imported mesh showed up, the “hairs” returned to my other Rhino model which was open in the background!

I tried restoring the Display Mode defaults in the preferences again and I quit and reopened Rhino several times, but as of now Rhino is still hairy! I think this may be related to importing the IGES file, since I had done that several days before I encountered the problem the first time. I will see if it magically disappears tomorrow and will try to re-import an IGES mesh file again.

I know this. This happens to me always over night after waking up the macbook.

I figured out changing once the checkmark GPU Tessellation in preferences / OpenGL solves this until next time the mac wake up. Then you have to change again.

German: Thanks for your response and I am glad to see that I am not the only one experiencing this. Of course, the issue disappeared after the next wakeup. but I will keep your tip in mind for when this happens next.

Same here! Hairs are appearing after importing an IGES file for the first time on this machine recently…

Did German’s solution above fix your issue? I haven’t had the issue happen again since I turned on GPU Tessellation (I guess it was off by default).

Seems to be gone after turning on the GPU tessellation.