Some custom display modes become 'Shaded'

Recently some of the custom display modes I’ve made turned into ‘Shaded’. I can re-import them and then they work as they are supposed to. But after restarting Rhino they are gone and multiple display modes named (and behaving like) ‘Shaded’ are in their place.

I have been using those display modes for several years now and last few weeks they keep turning into Shaded. Newer display modes I made recently remain available and working after restarting Rhino. I thought about recreating them, but since we use those display modes company-wide I would prefer I can use the current modes.

Any suggestions what could solve this issue?

open rhino and run the systeminfo command- paste the result here.

Systeminfo:

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Commercial, build 2023-02-27
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [61% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 3-9-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce RTX 2070 Super with Max-Q Design (NVidia) Memory: 8GB, Driver date: 1-15-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 528.24
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

Secondary graphics devices.
Citrix Indirect Display Adapter (Citrix Systems Inc.) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).
> External USB display device with 8 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-15-2023
Driver Version: 31.0.15.2824
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
D:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
D:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\7825\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0

Rhino plugins that ship with Rhino
D:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
D:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
D:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
D:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
D:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
D:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
D:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
D:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
D:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
D:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.28.23058.3001
D:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
D:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.28.23058.3001
D:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
D:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
D:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hey Kevin -

Is that as reliable as it sounds? That is, does that happen every single time? With the following exact steps? You probably delete the duplicate “Shaded” mode, import your custom mode, exit the Options, exit Rhino, and then restart Rhino → Your custom mode is back to “Shaded”.
-wim

That is exactly what happens. And the weird thing is that it only happens with a few display modes. Most of my custom display modes remain after restarting Rhino.

Hey Kevin -

Thanks for confirming that. We’ve had some very few reports of this behavior before but never something that was reproducible.
What happens when you disable your 3rd party plug-ins and restart Rhino and go through the same procedure? Does your custom display mode still get renamed?
-wim

Restarted Rhino yesterday without turning off the 3rd party plug-ins and miraculously the display mode remained. This morning, after starting up my laptop, it was still working…

Only thing I did different was importing only one of the 3 display modes that give/gave errors. I will keep checking if during today the display mode will turn into ‘Shaded’ again.

This happens to me almost daily. There was a post about it a fortnight ago

I thought it was just my laptop ?

Since my last post it remained working properly, but this afternoon it occured again. Now with a lot more custom display modes. I also ran short of disk space which happened earlier when the errors occurred. Perhaps that is the cause of this issue?

Edit: Just restarted Rhino and noticed all recent files where empty. Seems some kind of cache is cleared. Found that remarkable.

Edit: Also all my preferences are reset to default :frowning:

Hi @Kevin_van_der_Weijde and @o-lit,

Do you guys have VisualARQ or Lands Design installed?

I’ve received some reports of similar problems, but I’ve never been able to reproduce them, so not sure if VisualARQ is involved or not.

Since VisualARQ 2.13 and Lands 5.7, we save and restore all custom display modes that are copied from one of our display modes (“Conceptual”, “Realistic” and “Hidden”), as we have extra information for these display modes.

Have you created your display mode copied from any of them?

Enric

Hi Enric,

Yes, I did have VisualARQ installed but the error was only occurring on my old computer (7+ year old boot camp macbook pro). I have since upgraded to a new HP a month ago, and there has not been a single issue with the display modes dropping while having VisualARQ installed. I assumed it was just my old computer graphics driver failing.

The display modes I was having trouble with were personally created ones.

Hi Enric,

Yes, I do have VisualARQ and the problems started around the same time (cannot recall the exact timing).

I did not create a display modes based on those related to VisualARQ.

Hi @Kevin_van_der_Weijde,

Which version of VisualARQ and Rhino do you have installed?
Do you have any other third-party plugin or Grasshopper add-on?
Can you please try to see if disabling the plugins “Tibidabo” and “VisualARQ” fixes the issue?

Thanks,

Enric

Hi Enric,

  • Rhino version 7.28.23058.3001 (2023-02-27);
  • VisualARQ version 2.12.6.16419 (2022-09-01).

I also have V-Ray installed (latest version) and multiple Grasshopper add-ons.

The last few days I had no issues with the disapearance of display modes. If it occurs again I will disable both plugins to see if that will fix the issue.