Help please - credentials not working on Rhino.Compute server

Hi

I have followed the guidance (deploy guide) for deploying to our server’s Windows10 VM.
I have set up the core billing.
I have run the bootstrap.ps1 script and restarted the VM.
I confirm that the new Compute.Geometry service is now listed in the TaskManager but status is stopped.

When i try to start the service it is throwing a login error.

The compute.geometry service was unable to log on as .\OCON5376 with the currently configured password due to the following error:
The user name or password is incorrect.

The bootstrap.ps1 had advised to use the following username

    'Installing compute.geometry as a service...'
    "TIP: For the username, use '.\ocon5376'

I followed the tip and used “.\ocon5376” but is this actually the correct username to have provided?
‘ocon5376’ is my Windows User account that I am logged into our server with - is that the correct username to supply? Should it have ommitted the “.” ?
Does it have to be an administrative account rather than a plain user account? Should it instead have been my Rhino account username ?

For the password, confirm password prompts I made up a new password. Should this in fact have been my Rhino account password ?

Would appreciate any help.
Thanks
Dan.

For getting the service running you should be using your Windows credentials, the username and password you use to log into Windows on that machine.

Hey Dan,

The bootstrap script is designed to be run on a Windows Server OS. Core-hour billing isn’t supported on Windows 10. We haven’t yet updated Rhino 7’s EULA to cover running Rhino without core-hour billing for server-client workflows, where the number of “login sessions” might not accurately reflect the number of simultaneous users.

Are you able to use a virtual machine with Windows Server (2019 recommended) instead?

@brian Where did we land on running Compute in “production” on Windows 10? Is it supported and, if so, what’s the proper way to license Rhino this scenario?

To expand on Luis’ answer, when installing the service the username should be the Windows username that you want to use to run Compute. This is usually the username that you’re running as (as suggested by the script). The username needs to be in the format “domain\username” or “.\username” for a local user account. I’ll tune up the bootstrap script to make this clearer!

No. To use core-hour billing, you need to be running on Windows Server or Docker.

Core-hour billing is not supported on Windows desktop editions.

@brian , @will , @fraguada - guys thanks for getting me sorted out - i’ve moved to Windows Server 2016 and its running happily now. :slight_smile:
(for sake of anyone else landing here - my mistake, as the guys pointed out, was that i was supposed to use my Windows login credentials/password and I put in my rhino details instead - too many late nights!! :man_facepalming: )

1 Like

Awesome. Glad you got it working!

Guys I can ping http GET and POSTs locally on my laptop (http://localhost:8082) fine.

However my Windows Server 2016 deploy is fine with http GETs such as the /sdk endpoint but is rejecting http POSTs with a 401 Unauthorised.


I think it is not liking my ComputeServer.AuthToken but I’m not quite sure what value I should set this to? I have tried setting it to the Rhino.Token environment variable on the VM but this has no effect. I also tried setting it to my core-billing authentication token (crazy long string) but this failed also.

Can someone advice what this is supposed to be set to?

Download the latest version of RhinoCompute.cs and set ComputeServer.ApiKey to match the API key that you set on the server.

1 Like