Hearken Ye, All Developers - Running Rhino on VMware 15.0 Resulted In _ _ _

Success.

Although not officially supported, I just tried to run Rhino 6 on VMware 15 and surprise, surprise, it seems to work very well. Even GPU rendering with Raytraced works without any moanings or complaints (using a GTX 980Ti).

Better support for NVMe disks enables me working with big files (CT-scans) without spending the workday waiting for file loading and saving.

I had this on my wishlist for long, not primarily for designing with Rhino, but for Grasshopper development with Visual Studio including GPU programming, and now it seems that it just worx.

Just wanted to let you all know. I have tested on the Workstation Pro version, but haven’t tried the free VMware Player yet (I’m myself on the 12.5 version still, but it seem like it’s time to move on to v15).

More info here: https://blogs.vmware.com/workstation/2018/09/workstation-15-is-here.html

// Rolf

Disclaimer: I’m not affiliated with VMware in any way.

3 Likes

What does _SystemInfo on the vm say?

Here:

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Commercial, build 2018-11-07
License details: Cloud Zoo. In use by: RIL ()

Windows 10.0 SR0.0 or greater (Physical RAM: 2Gb)
Machine name: W10_ORIG
Running on a virtual machine: VMware Virtual Platform

SVGA3D; build: RELEASE; LLVM; (OpenGL ver:3.3 (Core Profile) Mesa 18.0.0 (git-6949e96035))

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: VMware, Inc.
Render version: 3.3
Shading Language: 3.30
Driver Date: 7-26-2018
Driver Version: 8.16.1.1
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp"Toolbars" 6.10.18311.20531
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

// Rolf

I guess the Raytraced HUD says NoGL?

Yes it does. I didn’t see that at first,

// Rolf

That is ok. It means my code works (:

Can’t you be more aggressive and grab the metal? :slight_smile:

// Rolf

VMWare gives OpenGL 3.3, for faster drawing I require newer than 3.3, effectively 4.0

It would be nice to be able to code against the GPU directly from VMware, but it seems like that is a bit complex, if it’s possible at all.

I saw in some video (lost the link) that a certain “Jessie” at Microsoft actually got through to the GPU on Windows Subsystem for Linux, but it was a lot of tweaking. It seems like we’re still in the dark ages with VMs.

// Rolf

This is indeed good news! I will test on a Linux host with VMware.
I did manage to get Rhino 5 working on Linux on top of the Wine layer, I think 32bit only… it was working well for the most part, with the occasional crash. Rhino 6 no such luck.

I had it running on a Linux host vm using VirtualBox but it was too buggy and slow… unusable.

Maybe this will finally solve my long standing dream of a Linux version… sort of.

Correct, it does not work. I have tried also.

Also correct. VirtualBox does only OpenGL 2.1 or so, which is not high enough for Rhino.

You are using Raytraced on the GTX (click on the Raytraced name in the HUD, it should show the render device name as well) still I guess - if so then Raytraced is ‘using the metal’ (:

added: capture of render device info in HUD after clicking on Raytraced name:

kuva

I get the following when clicking on “Raytraced” (my ol’ 6 core i7 3930):
bild

// Rolf

Aww, no GTX. I suppose the Tools > Options > Cycles | CUDA page looks empty. It is up to VMWare to get their driver support ready for CUDA usage.

And your i7 3930 is 8 logical core - by default Raytraced uses max(1, (NUM_CORES - 2)) threads - the x6in the hud in your case. In my HUD I have x2 because I have a meager 4-core Mac.

Very empty, yes:

bild

And yes, you’re right about 8-core. Happy to discover yet another two cores after so many years :wink:

Edit: But hm, I still don’t see more than 6 cores when looking at the task manager:
bild

Edit2: Now I’m really messed up. Of course the numbers in the screenshot were from the VM’s counters, not from the host machine:
bild

So yes, 8 logical cores.

// Rolf

Dunno how that works really.

that shows 6 cores, and 12 threads - which IMO would mean 12 logical cores. But with VMWare in between I don’t know.

Fake cores. :slight_smile:

// Rolf

Delivering on my promise, I did test the latest Rhino trial on VMware15 Player on a Debian 9.6 host and Windows 10 guest.
The test wasn’t thorough but it runs almost like on a physical Windows machine.
(Beware if you have a Nvidia Optimus system you have to go through some loops and make sure Nvidia graphics are used when running the VM on a Linux host, otherwise forget it.)

Below, a screen capture of the OpenGL settings used with the VM.

Screenshot_20181221_160422

Now, you should know that antialiasing means trouble! Don’t use it!
And you will run into some surprises working in rendered view, applying materials and other stuff related to rendering.
So far, for basic stuff, especially if you don’t leave the modelling environment too much, it seems reliable. But PLEASE!!! McNeel, think of your Linux users!!! I beg you!!!Or else we’ll all have to settle for FreeCAD :slight_smile:

1 Like

Hi, thanks I tried it today and it works with a Dell Precision and kUbuntu 20.04 guest and Windows 10 host on vmware player 15

How can I make sure I am using the Nvidia graphics card in the guest ? I don’t see any options related or graphics card in the wmware player settings.

If you can use it in a Windows guest and a Linux host?!, you probably already have installed Nvidia proprietary drivers. Recent Nvidia drivers for Linux already account for Optimus technology which switches between on-board and discrete graphics. Before you had to install Bumblebee and go through some hoops or you’d get black viewports (I did).

I guess the thing with going against the tide is that it always depends …

Thanks. It does run very nicely, the only problem I have had for now is that the points are not displayed, they exist but I can’t see them in the viewport. Do you have the same problem ?