WIP won't start after first run on VM

#1

Unsure if this is 100% compute related, but I’m running into it while working with compute.

I’m trying to set up another instance of the rhino/grasshopper compute server set up this past weekend at the TT hackathon. I’m working off my branch here. It works as expected on my laptop through localhost.

While running on a Google Cloud VM, though, it (seemingly randomly) will either hang on initialization here or throw an error: Rhino license manager initialization failed with error -200. Rhino will not run

I’ve re-installed/repaired/restarted multiple times, and run as an admin or not. Most times, Rhino WIP launched after a fresh install, crashed before I could interact with it, then wouldn’t open again. One time I managed to start in safe mode and disable all the plugins. But even after that first run, it wouldn’t reopen. This happens on both versions tested: 7.0.18289.06475 and 18297.06095.

Is there anything else I can try? Rhino 5 and 6 work on the VM.

0 Likes

(IVELIN PEYCHEV) #2

If Rhino allows working on VM it could be easily cracked. I don’t think it should work on VM and that is the problem.

0 Likes

#3

I hope that’s not the problem. I’ve had success before following their instructions here.

0 Likes

(IVELIN PEYCHEV) #4

I hope it is, otherwise using single-user license on multiple machines simultaneously would be as simple as creating snapshots from the VM and distributing it.

I don’t think VM is mentioned there.

0 Likes

(Steve Baer) #5

We had some problems with the latest V7 running on the Windows Server environment that platforms like Google and AWS provide. I’m not sure if this has been fixed yet. @will and @kike know more details about this than I do. I know this was a high priority item to fix, but I don’t know if it has been fixed yet.

0 Likes

(Will Pearson) #6

Hey @Chuck_Driesler, the bug that Steve mentions hasn’t been fixed yet. Unfortunately we’re in a temporary situation in which the latest version that works on Windows Server doesn’t include the necessary code to make it compatible with the version of Compute that you guys worked on in NYC. We’re on it though!

0 Likes

#7

@will Totally understood, thanks for the reply. This isn’t even a little urgent. Just wanted to check in before putting in more time to debug.

0 Likes

(Will Pearson) #8

Hey @Chuck_Driesler, we’ve just released a new Rhino WIP that should work on Windows Server!

2 Likes

#9

Thanks for letting me know @will!

I just updated on my machine (received version 7.0.18310.3365). I can now reliably launch safe mode. Normal WIP also gets much further into startup, but now it consistently crashes when it reaches the “preparing viewports” phase shown on the splash screen.

Since safe mode works, does this sound like something is probably wrong on my end? I’m happy to share a login with you if it would be useful to take a look at the VM.

Here’s the crash dump:

RhinoCrashDump.3dm (11.8 KB)

And the specs shown on the desktop (am on a Google Cloud VM):

0 Likes

(Will Pearson) #10

Sorry to hear that… I just tested the latest public WIP on Amazon and Google VMs and both worked fine. Which base image did you choose when launching your VM? I used “Windows Server 2016 Datacenter”.

0 Likes

(Will Pearson) #11

I went to shut down the Google Compute VM and found that Rhino had crashed. I just didn’t wait long enough. Logged as RH-49374.

If you can use Amazon EC2, while we look into the problem with GCE, then please do. That’s what we use for Rhino Compute and it’s working well with recent builds of Rhino WIP. They also have a free tier for the first year.

1 Like

#12

Will migrate over, thanks for checking and letting me know.

0 Likes