HDR Dome Light Issue

I am having an issue with the HDR images in the Light Dome. When rendered the image behind the model looks to be very, very blurred - where there should be clouds there is just a color which appears to be a blend of the colors in the light dome. See images below.

Everything else works, the model reacts to the light dome and the color behind the model changes if I rotate the dome, but there are no details in what should be the sky. See image below, there should be clouds behind the airship.

Also the preview window in the asset editor sometimes does not show the HDR and remains black.

Any suggestions folks?



I’m using VfR2 only and there I would check texture placement set to spherical?

Can you show the HDR map file?

Thanks for the message, Micha. Yes the texture is set to spherical.

Foreigner, how would I do that?


This is the preview image of the HDR. I am not able to upload the HDR or EXR files.


Try to check V-ray dome light settings .


This has only started happening in the last few days, everything was working as it should prior to that.

I have checked and rechecked all the settings. Notice in the third image the background is green, which would be the land.

Think I have this sorted now. Thanks for the help everyone.

1 Like

Hi Paul
I have the same problem now.
Can you please share the solution for this?

Does anybody please has an idea how to solve this?

I have a suggestion that has helped me GREATLY during trouble-shooting. I call it the render buddy. Yup, its a dumb name, but it actually works great.

  • Make a sphere and position it where the camera can see the whole thing without blocking too much of the scene.

  • Apply a shiny / polished chrome / mirror material to the sphere.

  • Render your scene.

The sphere’s reflection will show you the entire scene > above , below and behind the camera. You’ll be able to spot problems pretty quickly. For example, it will tell you if the environment map is loaded or not … and you might see some other lights you forgot about.

Thank you, render buddy!

1 Like

I switch camera type to “VR spherical panorama” for this need. :wink:

1 Like

I never tried that! I will do it soon to see how it works. Thanks for the tip, sir.

I use it often for interiors if I want to show the current setup of the whole scene and I don’t want to render every detail image by image. Best you set the camera at the middle of the room and horizontal aligned, the view menu “Set Camera -> CPlane Right” or something like this helps to do it too.

in Next, you don’t need to do this, just the camera position is enough

1 Like