Gumball snapping oddly

I have a custom workspace scheme for V8 and in that scheme, the Gumball is acting weirdly - when I click on a scale handle it snaps somewhere and then I have to bring it back to where I want. In my stock unmodified scheme it doesn’t do that. The settings are identical - I have even reset them to default in both. Anyone have any idea what is causing this? I seem to remember back in the V6 days seeing something similar for awhile, but not since then. Hidden setting somewhere?

The first one in the video shows the default, the second one is the custom. Note also that the scale handle is not in the same place in the second. The rectangles are the same size and position.

Edit: Here’s another video - note that in the default scheme, the Gumball scale handles change length to stay on the object as I zoom in and out. In the custom scheme, the handles have a fixed length, so zooming in and out puts them either inside or outside the rectangle. I also checked in advanced settings and there is nothing I can see that is different between the two.

Custom scheme as in a custom window layout or? You’ll need to export it and attach it here as I can’t reproduce it currently.

Rhino scheme…

It contains all of my customizations including the Window layout plus all the other Rhino settings. I have other Rhino schemes for starting Rhino with basically default settings and in different languages for testing/teaching.

I don’t know how to export all the stuff from my custom scheme - Window layouts, yes, settings files yes, what else?

As far as I know (and that doesn’t necessarily mean much), everything should be in the settings-Scheme_xxx.xml, window_positions-Scheme_xxx.xml, and the corresponding Scheme_xxx folder. If that’s what Joshua needs, you’d have to put those together in a zip file…


I believe so since it’s reported as only occurring with your scheme and not the default scheme

Sent by PM

1 Like

For people watching, @Joshua_Kennedy figured it out - it’s the GumballScaleSetting, set to Relative. Setting it back to Absolute restores the “normal” behavior. That setting is not in Gumball settings nor Options>Advanced, you have to type the command at the command line. He made a bug report to fix that.

1 Like