Gumball repositioning and snapping behavior

In R7, I often would hold Ctrl and drag the gumball to reposition it, and after holding ctrl, I would hold Alt to snap the gumball to a new part of the object. In R8, it doesn’t appear this behavior works. In R7, it allows you to press CTRL to start repositioning the gumball and let go of CTRL.

just tested here, that behavior works in the latest version of v8.

hold ctrl to relocate, then hold alt to use osnaps.

In V8 you need to hold Ctrl.

Press and hold Alt to temporarily toggle osnaps, tap Alt to make a duplicate

Do you hold Alt because you have Osnaps disabled?

I like the way it works in V8 but there’s something which confuses me

Below is a video from V8:

  1. Osnaps enabled. Hold Ctrl to drag the Gumball to the upper surface, snapping to a corner.
  2. Hold Ctrl + hold Alt to drag the Gumball to an arbitrary position temporarily deactivating Osnap.
  3. Osnaps disabled. Hold Ctrl + Alt to drag the Gumball back to a corner.

When the Osnaps are disabled, holding Alt is needed to temporarily enable Osnaps. Dragging the Gumball and holding Alt causes the Gumball to think it should copy the object. The (ghost) object moves with the Gumball. But I just want to relocate the Gumball. Once the mouse button is released, the ghost object disappears.

In V7, again with Osnaps disabled, I can hold Ctrl and Alt and no temporary object is visible.

The ghost object display should not be there and needs to be fixed in V8

agreed, the ghost object should not be there-

1 Like

Ghost object.

Thanks Kyle.

I see that it’s working for me now. Could there be a way to toggle whether we have to hold control or not the entire time when relocating the gumball?

the decision was made to change it to hold/ no hold because too many people had trouble with the ctrl before or after move process. It’s more binary now and should remove an undo if you get the sequence wrong.