Gumball misalignment on SubD

I’m trying to model a simple shape in SubD and I’m getting bad results using the scale widget on the gumball. In the pic you can see I’m sub-object selecting two edges (which are symmetrical around the Y axis) and the Gumball scale center is offset from the Y axis, so when I scale using the gumball the result is asymmetrical. Scaling the same two edges without the gumball and picking the Y axis as the scale center gives perfect results… Is this a bug, or am I doing something wrong?

Have you tried the comand _GumballAlignment? It has options to align to object, c-plane, or world. I’m not sure if that is your issue, but it might be worth a try.

It’s set to World so it should be centered… (shrugs)

Gumball often captures points from the back of the model.

Well yes, I want it to… Here you can see the points/edges I’m selecting (which I am certain are symmetrical) and you can see the gumball is offset…

Can I get it on the file?

Oddly, aligning the gumball to the object puts it in the correct position, but as the object is centred on the Yaxis this is still a puzzle…

SubDPuzzle.3dm (75.9 KB)

It seems like a mistake.
In flat mode draws correctly, in smooth mode the bug.

Yup, looks like a bug…

OOH! the Gumball Drag+copy works on an edge-loop, Nice!

Oh, no it doesn’t, just copies the edge curves as a separate object rather than inserting an edge as I thought it was doing… (blushes)

InsertEdge - command

Yes thanks, found that by typing it. Odd that it’s not on the SubD toolbar tab by default. Wonder what else is missing? :face_with_raised_eyebrow:

There is a label on the toolbar. If you can’t see them, dial ToolbarReset and restart Rhino.

Hmm I’m not seeing that…
If I float the SubD toolbar (Tools/Toolbar layout…) it shows the same buttons that are on the tab…

Surely this is the obvious place for SubD commands…

  1. ToolbarReset - command,
  2. Restart Rhino 7 WIP.

Well thanks , yes that worked at the same time as destroying all my personalisations… :man_facepalming:

Best practice is to make a new RUI toolbar collection file, and put your customizations in it, so a ToolbarReset that replaces default.rui will not wipe them out.
All you need to do is open your RUI again.



Thanks @John_Brock et al…

Actually this whole topic is about to become irrelevant to me as I’m running Windows 7 (I know: dinosaur :laughing:), so in two days I won’t be able to play with R7 WIP, until after my long-postponed entire system rebuild. Argh!
…unless you would allow me to extend the trial period of the current build? (I guarantee I will be upgrading to R7 when it is released… :grinning:)