Gumball disappears 2022 version 7 Win 10 pro

I have read the two threads, 2013 Strange Gumball Behavior and 2019 Gumball disappears. I have the same issue on an old laptop as per the system info below. I can use the invisible gumball! It appears when making a selection and can see it if I move the mouse away from it; but if I move toward it, it disappears. Drivers and Rhino version up to date, Intel graphics disabled. Other recent nonsense includes the desktop icons moving to the secondary display which is a WACOM Cintiq Pro 24. I have recently installed a flight simulator and a joystick and logitech multi pc keyboard and mouse. But I have tried to disable / undo as much of that as possible. The gumball works fine in ZBrush, MOI, and Modo. I also have selection problems on SubDs ands the selection box is not visible. Same using mouse or stylus, Wacom or PC screen. Thanks for any ideas on a solution.

Rhino 7 SR18 2022-5-4 (Rhino 7, 7.18.22124.03001, Git hash:master @ b2a1120bcb32e1f6da66a421cd7162a18a9f0cd9)
License type: Commercial, build 2022-05-04
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.

Secondary graphics devices.
NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 10-10-2018 (M-D-Y).
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-1-2018 (M-D-Y).
> Integrated graphics device with 0 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

An integrated accelerated graphics device exists and is attached to a monitor, but it’s not being used by Rhino.

  • Recommended: Use Windows’ Display Settings to configure one of the other monitors to be the “Main Display”.
  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-10-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\GWM2\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Hi -

There appears to be an April 2022 driver for that NVIDIA GPU:


Hi Wim,
Thank you, I have updated the1060, but still have the same Gumball problem.


Hi Gary -
From the SystemInfo report, it looks like the Intel GPU is still being used by the system - else it wouldn’t be found.
What happens when you disconnect the external monitor and only use the laptop screen?

Very odd… If I disable the Nvidia 1060 the Gmb works but the Wacom is not recognised. The Intel was showing as disabled. It offered to start in safe mode once and that worked for a while.
I plugged in a IIYAMA 24 in monitor and the same thing, not reconised with intel driver only. restarted the NVIDIA and its recognised but the Rhino Gmb disappears. So it would seem to be some setting or incompatibility with the NVIDIA 1060. There is a twist… I accidentally had two instances of Rhino open and one continued to work fine with the Intel and the Nvidia and IIYAMA all active. Go figure! I’ll retest that later see if I can start on the Intel only and re start the NVDA and have the 2nd monitor/ Wacom active… not that I need the WACOM for Rhino, but a larger monitor is useful. Thanks again.

Yes, I can start Rhino 7 with the Nvidia 1060 card disabled, then start it. The gumball continues to work. I don’t call that a solution but it is hopefully a temporary workaround until the next-gen 4 series GPUs are out.