GroundPlane's shadows, reflections and roughness


#1

Okay. :slight_smile:

This first result is not really surprising. When using a ground plane with Use a material we get a (ugly) horizon and nice shadows.

But when using a ground plane with Show Shadows Only we get no horizon, but totally different and ugly shadows:

I don’t know whether it’s a bug, but it would be nice to have something like Show Shadows Only with reflections or Use a Material without ugly horizon


Backdrop intersecting with turned off ground plane. (Or sth. like that...)
(Nathan 'jesterKing' Letwory) #2

Is this on CUDA or OpenCL?


#3

I have a GTX 770 and haven’t changed any settings, so I guess it’s CUDA. (And I only use the light you see! Studio HDR for Reflection and Skylight are turned off.)


(Nathan 'jesterKing' Letwory) #4

Could you please attach the 3dm?


#5

I had to make a new one: shadows.3dm (216.8 KB)


(Nathan 'jesterKing' Letwory) #6

It looks like the constant fall-off for rectangular light isn’t working properly.


(Nathan 'jesterKing' Letwory) #7

Also, when the groundplane is set to shadow-only it won’t participate in the indirect lighting of the scene anymore. This could be re-enabled though, the problem was that an earlier assigned material (i.e. red) would cause the invisible groundplane to generate red indirect diffuse lighting.

We have some ideas to improve that by using the environment color by casting an extra ray to determine that when groundplane was hit with a shadow or glossy ray.

I’ll keep you posted.


#8

Is this bug important or is it just a very low priority thing?


(Nathan 'jesterKing' Letwory) #9

All issues are important - to get as many features done this one has a bit lower priority for now, because it needs changes in the core requiring more time.

As said, I’ll notify when I’ve fixed this.


#10

Okay, thank you…