Groundplane - too many cooks

There’s too many places where the attributes of the groundplane can be adjusted.
I recently had to change the groundplane color, and it took ages for me to get there - its only because I finally recalled that it used to be set as part of the render settings that I got there.

This needs to be cleaned up - if there is going to be a panel dedicated to the groundplane, then surely that is where all the tools to do with it should be?

cheers
rabbit

@rabbit _GroundPlane brings up the Groundplane panel and its settings. In Render Settings, depending on the mode you are in (studio or custom) there is a checkbox to activate Groundplane + a button to bring you to the Groundplane panel.
In Rhino options the Render panel info is replicated in Document Properties > Render

Other than that I don’t think there are other places where the GroundPlane can be accessed, unless I’m missing something.

So now when I enable the ground plane panel I get:

‘Ground plane is not available when Studio render preset is active.

Click here to switch to custom render preset”

What does this even mean? I have never heard of ‘studio render preset’

Help says nothing about it…

Anyway, I ‘click here’ and now I’m in the standard ground plane dialog.

This contains

  • a check for show on/off
  • A check for show underside
  • Option for automatic or manual setting of the ground plane height
  • Option for show shadows only
  • Option for use a material

Where is the option to select / change the colour?

I get that the background colour is seperate from the ground plane, although if you are using show shadows only, you see the shadows on the background colour, (ie the ground plane is transparent but still captures shadows, which is a bit confusing but at least makes a contextual sense.)

Anyway, now the panel has become de locked in that the four radio buttons are all on and won’t go off.

Close and restart rhino to reset.

Ok, ground plane colour:

Use a material is the only option - it defaults to white.

So now I’ve got a white ground plane, showing in my rendered viewport, and also in my top viewport which is set to shaded… this can’t be right?

Anyway, I guess to change the ground plane colour I have to alter the current material. I do this in the material panel and set the colour to a lurid green. This change is confirmed by the material icon changing in both the render panel and the ground plane panel, but the ground plane remains white.

Something is not right.

Well it stays like this until I go to options / render and there is a check for ‘ground plane’, and ground plane settings. Clicking this brings up a dialog that via a drop-down box allows picking of the new green colour, and the ground plane in the rendered view follows, but the top (shaded) view remains white.

Closing the options dialog returns me to the ground plane panel; it shows a drop down with the default material first, then the green colour, but clicking between them has no effect.

So clearly the ground plane panel needs some tuning up.

To my way of thinking everything to do with the ground plane should be available in this panel; and nothing outside it should override it with some legacy or custom command or tweak.

If it is desirable to access anything to do with the ground pane from anywhere else, then it should be directed through this panel.

This is not to say custom scripts or commands can’t do whatever they want, - that’s a different story - but the master panel must be just that.

And the same logic should hold true for all the other panels, because then the user has a clear and defined safe haven, a base where everything can be relied upon.

If it was desirable that there had to be exceptions to this, then the exception should be allowed via the Master panel specifically, via a radio button or whatever.

I’ve had to use an expensive and dedicated software program for years because the results it was eventually able to produce were very good, and because it was a niche application there was little competition.

That thing was the spawn of hell, because it was built up over years with one thing piled on top of another, and it’s endless improvements were plumbed in seemingly randomly on top of what was already there.

There were so many arcane ways of accessing and interfering with the brute that it became counterproductive to continue with it; fortunately several and superior alternatives are now available, but it still rumbles around out there like the ghost of the dinosaur it is, spreading misery and webs of confusion as it goes….

I’d hate rhino to become like that….

Cheers

rabbit