Lack of consistency when setting ground plane

Thinking loud: why settings above do not correspond with those below:

Ground plane from options panel takes a priority over the ground setting from side panel. It is confusing and hard to find where is the problem.

Not sure what you meam, both screenshots show the same values for the same settings…

If you switch off ground plane completely in a side panel it is still on until it is switched off in display properties via options panel.
Also, I made them look exact but try to play with ground plane in Arctic mode. Nothing is changed unless you adjust itvia options panel.
The proof:

A bit unintuitive indeed. This is controlled by the Custem / Render Settings setting:


Arctict is set to Custom, so that always overrides.

Logged RH-64095 Confusing ground plane handling for improvement.

I have figured it out before but it wish these settings were linked. Far easier to control the scene.