Ground plane texture problem

I have a problem with textures for the ground plane (I made this new file only for demonstrating the problem). File and texture map:

Texture problem.zip (4.4 MB)

I opened the ground plane panel and chose a material from the library (Architectural / Floor / Wood / Parquet dark reflective). I made a cube (1000 x 1000 x 1000 mm) and zoomed out (zoom extents). I deleted the cube -> the texture disappeared and the viewport turned white. Undoing delete makes the texture reappear.

I then switched to the texture in the zip-file (boards+03_d100) and adjusted the size at the bottom in the ground plane panel (texture mapping section) from 1 to 10. Rendered view looks ok, but raytraced view shows the old size (1) -> different mapping in rendered and raytraced views with the same bitmap/size.

Philip

Not sure yet what the problem is internally, but for now to get going forward:

  • In the groundplane panel scroll down to the texture mapping section and set size to 1x1
  • Click the texture entry above the mapping section, drilling into its settings.
  • Scroll down to its own Mapping section
  • Ensure Size x and y aren’t linked
  • multiply size x and y with 10

Now Rendered and Raytraced agree.

Yes, thanks! I did already tried that in another file and got it working (the file I’m actually working in). It’s a bit confusing having “size” in two different places - even if I (almost) understand why… My humble opinion is that the texturing and rendering stuff is too complex and would need an ergonomic overhaul.

In this test file, however… When I tried the settings you proposed I get this:

Rendered and raytraced do agree, but not the way I would expect. I can only see a brown bitmap color, but not the bitmap in correct size.

If I change the texture size to 10000 x 1600 (the correct size in millimetres) in the content editor the rendered viewport still looks like in the above screenshot, but raytraced looks like this:

Something is wrong. Is it my iMac - or Rhino on this iMac? I haven’t tried it on my MacBook yet (too much work right now).

System info: iMac Pro.txt (2.6 KB)

Philip

This ground plane business and its texturing is indeed confusing. Can you maybe share the 3dm of your last screenshot? The make of your Mac machine shouldn’t matter here

(end of theory).

It’s the file from my first post (I didn’t save it, so you have to make the size-changes in the file yourself)

No, but I have experienced some differences compared to my MacBook (see: Rendering frustration), so I wonder if rhino dislikes the better (?) graphics card (or processors) in the iMac…?

:grinning:

Philip

But you will probably not see what I see, so there’s something wrong with my setup…
I can open the file on my computer again, do the changes and save the file - and then send it. That’s what you meant, right?

Philip

Nooo, now I getting really frustrated… I changed the size to 1 - and in the Content Editor changed the size to 10000 x 1500 - and now I get the correct result…!?! How is that possible? I swear I did the exact same thing as before when I got the strange result as in the screenshot…

Here’s the saved file, anyway:

Texture problem 2.3dm.zip (2.7 MB)

Philip

Another thing though… I still get this. You have obviously not found a solution to this old problem, I guess @dan

Philip

I think the problem I see here is the use of WCS as the mapping. I need to check if I handle that properly.

I opened the file again and changed to mapping Chanel 1 (in the Content Editor) - and now raytraced doesn’t start at all (it just says “rendering”, but nothing happens. Changing back to WCS doesn’t help.

Philip

You shouldn’t be working this late at night! Raytraced gets upset.

I hope it is a one-off. I haven’t had that happen yet.

Nor should you :grin:

Obviously :slightly_smiling_face:

I have - this wasn’t the first time… Usually it helps to reopen the file, but not this time. Perhaps tomorrow…

Philip

I found a fix for the groundplane mapping problem when WCS/WCS box are being used in the render textures.

I have logged https://mcneel.myjetbrains.com/youtrack/issue/RH-55981 to ensure it is tracked properly.

1 Like

Thanks!

Philip

Were you able to repeat this as well - or is it my setup…?

Philip

I was not able to repeat that.

Ok - so there’s really something wrong with this setup/iMac. I probably need to reinstall the OS - and switch to Catalina in the process. I just have too much work now and wouldn’t like to spend a couple of days reinstalling everything…

Philip