Rendering frustration

I’m having a hard time with materials. It’s been a while since I had a need for “pretty pictures” - but now I do and I’m a bit surprised about all the bugs (?) that still exist. It could of course be me or my computer…

Anyway… When clicking the material button in the layers panel it takes aaages (everything from 30 seconds to about 1 min with 18 materials in the file) before the dialog opens (I don’t know what it’s called - the one where you can choose another material, that’s already in the file - or click the + sign and navigate to the material library to pick a new material). Sometimes it can take only (?) 10 sec - it varies. Very strange. If I go to the materials panel selecting a new material from the library is almost instantaneous… But I usually can’t assign that material to layer - it doesn’t work. The material doesn’t change! And in the “choose layer” dialog I can’t select layer by double clicking or pressing space anyway (this is one more dialog where space doesn’t work) - I have to press “apply.” Assigning to objects works.

That’s about it (there’s more, but I can’t remember right now). This is supposed to be a good computer (iMac Pro) - I haven’t even tried this (very simple) file on my little MacBook Pro.

I guess you can tell I’m frustrated - sorry about that…
I’ll send the file directly to McNeel (once again).


Finally I had to force quit. Rhino crashed. I sent the report to McNeel.

By the way… In I press the “send file” button in the crash dump dialog it only opens Discourse/How to report problems in Mac Rhino…?!? It should just attach and send the file!


Oh, by the way. Opening files with materials in them also takes aaages…


One more thing. In the layers panel I would like to see the material ‘name’ when hovering over the material “dot.” Now it just says “Default material for objects in this layer. Click to change” - which isn’t true…
The dot also doesn’t always change color according to the material chosen - which it should.


So… nobody can repeat these issues with the file I sent you? @dan
From my first post:

From my third post:

From my fourth post:


Hi Philip,
what version are you running? I am also experiencing slow material editor, some blackscreens when editing the texture and a lot of crashes when exporting raytraced image.



I now have 6.20.19315.01032, 2019-11-11 (downloaded today). I haven’t checked yet if it’s any better than the previous version on this iMac, but I doubt it as this has been going on for quite a long time.


I’m beginning to think that something is wrong with my computer as they (McNeel) don’t seem to be able to repeat it.


Honestly I am also having troubles with rendering / materials in the model. After importing/creating several materials either from library or custom made, the material editor is as slow as you describe (waiting time 10 sec is nothing unusual). I also experience issues with the preview of the material, changing its properties: fe. when doing colour corrections (multiply, gama…) to the texture, the whole screen goes black. All in all, the workability of such a file seems to be severely hardcore.

We seem to be having the same problems - I don’t get the black screen, though. This is quite restricting and almost prevents a normal use of materials in Rhino.
@dan, @pascal



Bring it over - let’s take a look.


Thanks Andy! I’ll call you next week.


I will also join in if possible.

Regards, Max

Ok, great - see you!


I have now tried that same file (I sent you) on my laptop - the first time I have tested a file with materials since the WIP-days on my laptop (when I discovered it was - of course - slower than my iMac). Much to my surprise it opened quicker than on my iMac Pro…! Also the other delays I was talking about were almost normal and acceptable. There seems to be something wrong with my iMac, which is very odd. I’m also having some problems with an other app on this machine - even if it runs smoothly on the MacBook…
So I guess I’ll have to consult my Apple service first, before taking up any more of your time @Andy and @maxsoder.

If nothing else helps I will have to reinstall my OS (and at the same time I’ll upgrade to Catalina). That means a lot of work with all the apps I have to install, but at least I get a ‘fresh’ computer.

I’m sorry for blaming Rhino, when there’s probably something wrong with the hardware or OS. There can’t be anything wrong with the combination of Rhino and my hardware, can there?

System infos:

iMac Pro.txt (2.7 KB) MacBook Pro.txt (2.7 KB)


This is, however, also a problem on the MacBook.


Hi @Philip,

did you manage to solve those issues with materials and performance via reinstalling OS? I am wondering if it helps. Btw which version of OS are you / were you running?


Hi! I didn’t reinstall yet. I haven’t done any rendering for a long time so I’m still using macOS Mojave 10.14.6 (18G95). I’ll get Catalina when a program I will be using is ready for Catalina.
So nothing has changed yet, I’m afraid…


Yes, nothing has really changed since November. All our macs have these performance issues with handling models with more materials whereas the windows platform was quite ok. Could be related to the Nvidia cards and the overall mac performance…?