Green highlighting


Sometime the green highlights on the Rhino screen don’t show up when I select object functions in grasshopper? Does anyone know how I can turn them back on?


On the grasshopper canvas -> right bottom, there is a green/grey brep icon. There you can toggle between display all or just selected. Or if your components are dark grey just right click on it and choose “preview”

Thanks, but this doesn’t quite seem to solve my problem.

I’ve noticed actually, that some functions work, but other don’t. Is there a setting that means that those inside grouped boxes don’t highlight?


No, but individual components can be hidden in the preview. Are they darker grey than the ones that do work?

No it still occurs on ones that have the preview switched on.

Well, in that case you’re going to have to start posting some screenshots.

Are there any messages printed in the Rhino command history btw.? If there’s an error during the preview drawing it probably will prevent further objects from being shown.

Also, if you have a component that describes the same object but was added to the canvas later than the one that you select, your selection will not turn green.

— When checking this to be sure, I see that this no longer is the case in GH1 - are you running Rhino 5?