Grasshopper preview dissappears when selected

Hello everyone,

is it just me or after the latest update of Rhino 6 the preview of Grasshopper geometry is very messed up? When I select a component in GH, it actually disappeares instead of being shown in green (or the color specified in the little menu). I experienced this on 4 different systems… What is going on? Is there some way to remedy this, or I have to downgrade?

Add some screenshots perhaps?

This just started to happen to me and I don’t know how to solve it. Did you find a solution?

So any selected (i.e. green) preview geometry is not visible? Settings are standard? No error messages in the Rhino command history?

–Me too! What happened?
[Yes David, selected geometry is not visible (nor any other!]
It seems to be file-specific to rhino file–I don’t have the issue in a NEW .3dm file in either v6 or v7.
v7 updated after I verified the same issue there, and everything’s back to normal!!! No idea if that’s all related, but happy for normalcy now.

Best I can tell, it started after opening either:
<> located here:;
<> loacted here:

There were some custom graph previews in both, some old components that I replaced w/ the current ones–no idea if that’s relevant.

Only error messages I see in RH are related to CAD block attachment:
Unsupported entity type: AcDbMPolygon, MPOLYGON
Unsupported entity type: AcDbProxyEntity, ACAD_PROXY_ENTITY”

File is not new, and haven’t had the issue prior to today…
I closed gh & RH & started a new gh file from scratch, but same issue; haven’t intentionally changed anything besides preview colors (along time ago, no recent changes–docs above have default preview colors, but hasn’t posed an issue previously).
Opened up RH7 WIP & it’s happening there, too–haven’t used WIP for several days before just now.



Version 6 SR24
(6.24.20079.23341, 03/19/2020)

ha! just kidding! The issue seems to be related (at least somewhat) to the Discontinuity component:
When it’s set to “Analytical,” point-previews appear normally in existing ‘Top’ view, but C1 & C2 settings result in no-preview as shown above. ‘Perspective’ view seems normal.

I’ve had gh blow up my viewports before, but not so stealthfully!

Proposed workaround: delete viewport, create new one, set view.