Grasshopper update December 2023 not responding

Hi All,

I have just updated my Rhino 7, and for some reason, I am now unable to load GH (well if freezes). It has been on this screen now for about 15 minutes.
Has anybody come across this and able to assist?



It might be that you have a GhPython error that is hidden under the splash screen. I have GhPython errors during the Grasshopper initialization and I saw other users having it too. I also had situations where an error was underneath the splash screen. You can try blindly pressing the Enter key to “ok” error window.

Are you opening a GH file?

What happens if you start Rhino without opening a file, then click ‘Tools | Grasshopper’ :question:

Not opening a GH file. Just trying to start GH.

Have a blank Rhino file at startup, Tools | Grasshopper, and have the same result

Tried hitting Enter - It wasn’t a fan of that. Screen has gone to “Not Repsonding”

Looks like I have the same version of GH that you do, though I have only a few plugins installed.


Try loading grasshopper from the Rhino command line with GrasshopperLoadOneByOne and say no to any 3rd party plugins.

Unfortunately, it still hangs even after clicking no on all third-party plugins

I have tested connected to the internet, and disconnected and the same result. Even if I hit no to all of addins, I still get the loading GHPyton loading message

All fixed - I had Autodesk Desktop Connector had a lot of actions pending. Once I completed the actions, all opened successfully