Grasshopper / Rhino UI

unhandled

(Baileyja) #1

I am currently running Rhino / Grasshopper on two monitors (grasshopper on one, rhino on the other). I keep having the issue where I try to type in numbers, commands, etc. into Grasshopper, but the GH interface no long recognizes what I’m typing and kicks me over to the Rhino command line. This means I cannot type numbers into sliders or insert text into notepad. It also means I cannot do any quick commands in the canvas or copy/paste/delete using keyboard commands – everything has to instead be dragged/dropped from the components or menu at the top of the UI.

I havent seen much online on how to fix this other than someones suggestion of going to the task manager and hitting ‘show desktop’… this has not worked for me and seems like a wholly inadequate solution. i seen that David Rutten had commented, but seems like there has not been a fix.

Is anyone on the GH development team aware of this, or is anyone else having this issue?

I am currently running Rhino 5.0 and GH build 0.9.0076. Maybe this is not an issue in R6, however I don’t use that often as there are VPN issues with the OpenGL Rhino6 uses – so I cannot work remotely when I need to.


#2

I’ve had this too, on R6. The only way I got rid of it was to testart Rhino, but I have not tried to dive deeper into why it happens, so there might be other ways to let GH regain and keep its focus.

// Rolf


(Baileyja) #3

Yeah I thought I had this issue in R6 also, but like I said I have not used it in a while so I couldn’t remember correctly… and the problem is not consistent… I dont know what kinds of conditions have to be met for this to occur.

I just know that it’s happening with enough regularity that’s it’s really disruptive to my workflow and I’ve been hoping there is a solution out there.