Keyboard shortcuts not recognised in Grasshopper

Think this might be a bug.
Finding that common keyboard shortcuts like copy, paste, delete etc are not recognised in GH all the time.
Have noticed if you have rhino on a separate screen, with GH active, when entering keyboard commands, nothing happens in GH, but the command line in Rhino is receiving the inputs.
Hope that makes sense.
It seems that after a while of minimizing, maximising, dragging, switching apps etc GH keyboard entry will start to work, but if you navigate to another window and back again, most times the keyboard entries will stop working again.

The cursor needs to be on the Grasshopper canvas and you will have to click once onto the canvas otherwise Rhino doesn’t seem to know you want to type something in Grasshopper.

Thanks for the response Martin.
I can work away from an hour or more in GH and still get the same issue.
I’ll see if I can do a screen recording.

If this is happening frequently it may be something else, but sounds a lot like this old bug that I’ve only come across randomly.

Keyboard bug GH-to-Rhino - #10 by Birk_Binnard

There’s a couple things to try but restarting Rhino is the only thing that’s worked for me.

This happens pretty much every time I use GH.
Have restarted several times, but always get the same result.
Even if it works for a bit, the moment I navigate to Archicad then back to GH, the keyboard shortcuts stop working.

Any idea how to direct this to tech support?
When clicking on the Grasshopper Support button within the help menu, I get directed to the user forum.

Can you replicate this without the Archicad aspect?

Yeah closed AC, Started new Rhino, started new GH. Issue occurs immediately.

Can you provide your SystemInfo (type in the command line). This sounds different than the unfixable one that happens occasionally.


Thanks @Japhy

Rhino 7 SR21 2022-7-27 (Rhino 7, 7.21.22208.13001, Git hash:master @ c31aea87137a5d0de449338a7ef6856f49dd4797)
License type: Evaluation, build 2022-07-27
License details: Cloud Zoo
Expires on: 2022-09-17

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2200 (NVidia) Memory: 5GB, Driver date: 6-3-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.02
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-3-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I note that it says “evaluation”, but I have a license as of 19/8/22.

Thanks, I was really expecting this to be from a plugin that doesn’t ship with Rhino, but you have none.

Lets get your nvidia driver updated and then look at the scaling/Alignment on your monitors.


Sweet as, hopefully these screenshots are sufficient.

I did a restart after driver update, opened RH on left screen then GH on right screen, was able to copy and paste, moved GH on to the left screen and lost ability to use keyboard shortcut entry again.

I downloaded latest driver from Nvidia website and installed.

Hi Josh -

Rhino doesn’t automatically change to a different license, so make sure to make the switch well before September 17. It doesn’t look like you’ve added your new license to your Cloud Zoo. If you need help with licensing, please contact

1 Like

This is atypical and we need to figure out if its something about the monitors setup.

Can you try going to just one monitor being used and see if that changes any of the behavior you are seeing? Thanks.

This is a bit of an odd connection, but I have also been having trouble with my license (going from evaluation to commercial).
I was able to resolve it earlier today, since then I haven’t had any issue with the keyboard commands.
It’s a bit early to know for sure, but at the moment it looks like problem may be resolved.
Will post again if/when problem resurfaces.

1 Like

Does this help:

Was an issue for a long time but haven’t noticed it recently.

So had a stint where was working fine after resolving the license issue, however this morning the issue has resurfaced. Tried the same troubleshooting as before, restarting closing etc.

If it’s of any use, here is another quick screen recording.
In this video, I have included the on-screen keyboard which hopefully shows the issue clearer.
Have also shown how the numeric entry is impacted as well.