Grasshopper Plugins not loading

I was recently teaching a friend how to use Grasshopper for Rhino 6, so I went ahead and installed all of my plugins (most which didn’t work) onto their Rhino 6 trial edition, and believe it or not every plugin worked.

I was wondering if anybody has ever ran into this issue, and figured a way how to work around it. I went ahead and messaged tech@mcneel and they said there were no Rhino 6 updates available at the moment.

Best regards,

maybe if you right click the gha file, go to properties, and unlock it will load
image

It appears that that didn’t do the trick. I just find it strange that downloading metahopper or other plugins like Elefront won’t load onto my Rhino when it is an uncracked version, and I donwloaded newest versions from food4rhino - I have tried installing plugins previously downloaded from friends, and haven’t had luck with these ones in particular - yet the same plugin file was installed on another friends computer and it loaded without any problems.

If you run the _GrasshopperLoadOneByOne command, what sequence of plugins are you asked to load?

David! I tried it and for some reason - it got Metahopper to load!

Maybe one more strange thing, for example, I tried installing Horster Camera Control which the latest update is for Rhino 5, and it worked on a friends computer but not on mine. Not sure how come either.

The load one by one approach allows you to figure out which plugin is causing problems, however it all plugins load fine this way then the problem seems to be one of timing. One of the plugins is doing something during its load process which fails when the load happens quickly but succeeds when it’s slow.
This does sound somewhat unlikely, so I’m hoping I’m wrong and there’s another explanation…

What you can try is deliberately disabling each plugin to see when the loading starts to work as expected. You can do this in Rhino6 by putting a file next to the plugin which has the same name, but a .no6 extension. So if you want to not load a plugin called SomeAnimal.gha, but an empty text file next to it called SomeAnimal.no6.

1 Like