Grasshopper kangaroo only work in mm


Is anyone having an issue working with m unit in Kangaroo for a very small object?

I am trying to simulate tensile behaviour of a Plastic sized 114mm by 114mm.
I wanted to work in M to avoid tedious unit conversion. However, it does not seem to work.

So I converted all the unit into mm value (Newton to millinewton, m to mm and so on) It started to work perfectly fine.

Wondering if there is anyone else had a similar issue.


What issue exactly are you having when using M?

One thing to watch out for is the ‘tolerance’ setting, which controls the distance below which points get treated as coincident and combined into a single particle. It is there to allow the input of imperfectly snapped geometry, but the default value is probably too high if you have very small objects.