Mesh settings / Kangaroo spring tolerance help


#1

I am trying to relax a mesh using Kangaroo in Grasshopper. The issue that I am currently having is that some of my mesh edges are below 0.005, which I gather the Spring component treats as 0. I need to either get the mesh component to respect the minimum mesh edge length, or change the Spring component tolerance setting, but I can’t seem to do either. Any ideas on how I can make this work?

Thanks,
Sam


(Bob McNeel) #2

I think @DanielPiker can help with this.


#3

Thanks Bob. As a workaround I’m scaling the mesh up, then relaxing then scaling back down which is working.


(Daniel Piker) #4

Hi Sam,
The Spring component uses the current Rhino document tolerance settings to check for near zero length springs.
You can change this in Tools>Options>Document Properties>Units>Absolute tolerance