Grasshopper in Revit is freezed

Hi all,

I am not able to open grasshopper in Revit 2022.1 I have updated the rhino to the latest version of V7.2

and the rhinoinsiderevit to 1.1. Please find the snip below.

But I am not able to open grasshopper in revit as it is showing freezed in the addin tab. Rhino is getting opened and if I try to open grasshopper in rhino using “rhinoinsiderevit” plugin it is not allowing me to open as it says it is blocking

Totally grasshopper is greyed out in rhinoinsiderevit plugin

Kindly let me know the solution and highly appreciated your response.

Hi Shaschank,

This could be a plugin conflict with another Revit Addin.

Can you provide the About info available here…

As well as open Rhino on its own and Run SystemInfo command in the command line?

Does Grasshopper open normally outside the Revit environment?


Hi @Japhy thanks for your quick response.

Outside revit environment, if I open rhino 7 and run the command grasshoper, it is getting opened but in revit environment using rhinoinsiderevit plugin, grasshopper is totally greyed out. But I am not understanding till last week I am able to open grasshopper but today if I try to run rhinoinsiderevit plugin, then grasshopper is greyed out.

Please let me know for which reasons I am facing this problem. I also check with which it is getting clashed.

@Japhy I have remove all the other addins and I kept only rhinoinsiderevit addin for Revit 2022. But not working, still the same issue.

Kindly let me know what would the possible solution for this?

Please provide the About and SystemInfo i mentioned above. Thanks.

I have checked the properties of rhino 7 inside revit using the plugin rhinoinsiderevit. I have enabled all the plugins. So it worked for me now. Thanks @Japhy for your help.