Grasshopper crashes while animating slider (Rhino 7)

Dear all,

I am currently working on an art animation through Grasshopper/Rhino 7 and its been driving me crazy with over 10+ crashes since last night. The project is confidential so I will not be able to share the files. But this has been happening while am animating a slider in Grasshopper. It just crashes half way through. Sometimes it doesnt, and sometime it does.

Video card and windows are updated. Any clues what the problem could be ? Am also using the gaming driver from Nvidia. Would it help to switch to the Studio driver ?

Hi Mohanned -

Can you reproduce the crashes in a different definition or with a modified / simplified project that can be shared?

I can’t find any crash reports from your eMail address. Does the crash reporter pop up after the crash? If so, please always send in that report.

Please run the Rhino SystemInfo command and copy-paste the result here.

I know that some prefer the Studio drivers and since you experience frequent crashes, you might as well give that a shot.

Yes will do so tomorrow. Its a simple point attractor that moves around while the original grid is being pushed by grid distortion forces. Am animating the movement of the point attractor.

No, the rhino crash report does not pop up. Thats why I started to worry that maybe my video card is dying. Even though I am a gamer and I play video games on my PC without a problem.

Rhino 7 SR13 2021-12-14 (Rhino 7, 7.13.21348.13001, Git hash:master @ 7696723f74a63695b3c372a89110c0ca8c78b890)
License type: Commercial, build 2021-12-14
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 11-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 497.09
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-26-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I installed the studio driver and it still didnt help. I also tried doing the slider animate on my laptop to trouble shoot and see if my PC hardware has a problem and the same thing happened again.

Been at it with continuous crashes for 3 days now. Let me know if you can help in anyway.

PS: I even tried exporting the images to the C:/ directory and it didnt help to fix it. (That used to be a problem with Lumion where it would not export a video if it wasn’t exported in the C:/ directory).

Hi Mohanned -

It sounds like it is easily reproducible, then. With a simple file that I’m testing, this doesn’t happen so I would need a Grasshopper definition from you that I can use to reproduce this.

Just to make sure… Lumion isn’t listed in the list of plug-ins. Do you have that plug-in installed and enabled in Rhino when you crash?

I can send you the file on your email but I will not be able to share it with you on the forums.

Yeah I am not using Lumion. I am using rhino 7 default render quality. Forget that I mentioned Lumion, it is a confusing reference.

Thank you

Hi -

You can then send that file to