Grasshopper Breakpoint PTComponentLibrary

panelingtools
unhandled
(Ysabellegamoso) #1

Hello everyone. I am new to GH and was recently following Ms. Rajaa’s paneling tool tutorial. PT worked well in my Rhino 6 but at the end when I am about to use GH I got the error message that is attached here.

May you please advise on this issue. I have Rhino 6 for Windows with PT working properly only on Rhino.

Thank you! Looking forward!

0 Likes

(Michael Pryor) #2

Update your Rhino 6 which will also update Grasshopper. It says right there that PTComponentLibrary is built against a newer version than you have. You are on 6.1, PT requires 6.3. I believe Rhino is up to version 6.9 currently. Just go to Rhino options > Updates and Statistics, and update to the latest release.

0 Likes

(Ysabellegamoso) #3

That makes sense! Will do, thank you.

0 Likes

(Pinenuthj) #4

Hello Michael,
I think I have a similar problems with Ysabellegamoso. toolbar show in Rhino, but not in grasshopper.
once I run grasshopper , it says, local SDK=6.6 Referenced SDK=6.1. I think I don’t need to upgrade my rhino right? since it already beyond it required. and then I want to run some "Bee“ plugins, it said,some components are missing,so i click the button to try to down load and then it shows like this.
%E6%90%9C%E7%8B%97%E6%88%AA%E5%9B%BE20190324164719

the PT i download is the .rhi file, besides click it and install it, what else should I do? Or it’s all my too latest version’s fault? do you have any idea?

Thanks,
Hazel

0 Likes

(Rajaa Issa) #5

@will this is a first example I see where the package manager tries to download PT. Note that this is a Rhino+Grasshopper plugin, and not sure if the install/update should be any different. Could you help look into this one?

0 Likes