Global setting for Dynamic Display

unhandled

#1

Hi all,
I searched all over but I cant find the global setting for Dynamic Display:

2c68e08bfef0583253fe5c7c4a5abe5ed4717df3_1_601x500

Where can I set this?

thanks, Tobias


(Wim Dekeyser) #2

Rhino Options > View > Dynamic redraw > Frames per second


#3

Hi Wim,
I was looking for a setting to turn of bounding box display all together globally.
Under each display mode > Objects there is Dynamic Redraw which can be either “Display objects bounding box” or Use application setting. So I was thinking it’s possible to turn it off globally.

thanks, Tobias


#4

In V5 this setting is 20 fps and no BBdisplay. In V6 20 fps shows Bboxes…


(Wim Dekeyser) #5

Hi Tobias,
I suppose that putting that setting at 1 is as close you will come to turning this feature off globally.
Have you tried unchecking the Rhino Options > View > OpenGL > GPU Tessellation to see if that makes a difference?


#6

Hi Wim,
Turning GPU tessellation on or off makes no real difference. The fps setting, even if I put it on 10 BBox display is basically off but it looks really ugly. Rhino 5 display is so much nicer… V5 works well with 20 fps.


#7

In V5 I can even set it to 50 fps and still get no Bbox display, but from the smoothness I can say it’s clearly not 50 fps… so I don’t know whats going on.

Still V5 looks MUCH better than V6.


#8

As far as curve and surface edge drawing goes, I would agree with you… All the rest is better in V6 IMO, but I still have a hard time with the bad AA on curves and edges.


#9

I meant “Still V5 looks MUCH better than V6” with respect to the dynamic redraw. I’m using an old card and things might be better with a modern card. I have a pro card in my laptop. I’ll install V6 there soon. Let’s hope it’s better then.

And yeah… curve and surface edge drawing is indeed hrad to bear. Can’t deal with those thick lines.


#10

I completely agree. Ever since I have this in my startup commands:

testWireThicknessScale Enabled=On Scale=0.7 enter

it’s less of an issue though. I assume the new thick lines have to be there to accommodate high dpi displays. I understood it might eventually be a configuration option in Rhino’s options.


(Wim Dekeyser) #11

It already is - though under the “Advanced” options:

Rhino.Options.OpenGL.WireThicknessScale

Note that there seems to be a problem with certain System Locale settings where you use a decimal point but that gets taken as a comma, resulting in thicker lines rather than thinner. That issue is logged as RH-45956


#13

Thanks for pointing that out. Not a very user friendly place to store this setting though, yikes.


#14

I use wire thickness scale to thin out the curves/edges, that is not the issue. The issue is that the AA on those curves is much poorer than in V5, so they look worse on-screen, even at the same thickness scale as V5 (somewhere around 0.6-0.7).


#15

It used to be worse but with Rhino.Options.OpenGL.Antialiasmode = 4 or higher it is just as good as Rhino 5 for me. At default of 2 it is very jaggy though


#16

Didn’t even know that setting existied, but I had Options>View>OpenGL Antialiasing set to 8x and it’s still not as good as V5. Setting Rhino.Options.OpenGL.Antialiasmode to 4 looks just awful here, it sets the Options>View>OpenGL Antialiasing to None…

I have no idea what that option is actually doing, I assume it it communicating with the video driver in some way… but it seems totally buggy to me, for example I set the advanced option to 8 and OK, then it shows a change on the screen; if I then go to the Options>View>OpenGL Antialiasing page it still shows “None” and if I click OK without changing anything, AA gets turned off completely (the advanced option gets set back to 0).

Also, if I set the advanced setting to something like 8 or 16, view rotation gets “stuttery”… So I gave up on that and just went back to setting antialiasing to 8x on the OpenGL page.

So no, I don’t agree that V6 is better than V5 in this respect.


#17

I think I answered too quickly after fidling with that setting. I too have antialiasing set to 8. It seems to correspond with Antialias mode = 3. (4 with 2 and 2 with 1)
Second time I’m trying this it behaves exactly as you described


#18

Maybe it has to do with the fact that I am using the arctic mode a lot lately. In this mode curves look much more refined than in the other modes. It seems to have to do with the gamma setting. Setting it to 1 instead of 2.2 makes the curves look exactly as in the other modes.
In rendered mode changing the gamma setting has no effect though…


#19

Same thing on my laptop. Laggy display and Bbox display all the time.
Ok, my laptop card is old as well (Quadro FX 3800M), but it’s really snappy with Rhino 5


(Wim Dekeyser) #21

Tobias,
I’ve been told that you can put the setting [ Rhino Options > View > Dynamic redraw > Frames per second ] below 1 - e.g. 0.001. That will completely turn off the Bbox display.
Groetjes,
w


I need help! I so much want to like Rhino 6