Gismo Terrain Generator Issues

Hi all,

I’ve been experiencing issues with the Gismo_Terrain Generator (TerrainGenerator) Component. It’s failing to gather the terrain data from It seems that this may be an issue on the component side or the REST services side of opentopography. Any insight on the issues in this component? I’ve hit this same error for multiple days now. Prior to this issue, the script I was using this in worked seamlessly.

Edit: I’ve downloaded the latest build from the git repository and still face this issue

Hi @steve.danilowicz ,
I just tried to run Terrain Generator component with different random locations and new radii - it worked without any issues.
Can you attach your .gh file please? You can delete your Terrain Generator “_APIkey” input.

Sure thing. Here’s the file. I’m not seeing an _APIkey input, and haven’t used one in the past. Perhaps that’s the issue?
Site Importer - GISMO.ghx (3.3 MB)

1 Like

Hi @steve.danilowicz ,
Thank you for the attached file.

Yes, since May 2021, Terrain Generator component requires an APIkey.
You can get one for free, by following this short video tutorial (click on ‘Download’ button to download the video file).

  1. Once you obtain the APIkey, download the newest Terrain Generator component from here.
    Once you download the newest component, right click on it and - Unblock it.

  2. Then delete the old component from folder:

  3. And paste the newly downloaded one.

  4. This will enable to drag the new Terrain Generator from the ‘Gismo’ tab. Replace your old component int the definition with this newly dragged one.

1 Like

Sorry for the belated reply here. Finally had the time to get to this. The solution you gave me worked perfectly! Thank you again for the help @djordje!

1 Like