GISMO: TerrainGenerator Issue

unhandled
gismo

#1

Hi @djordje

I am just giving Gismo a whirl for generating topographic terrain data. When I run the analyse_terrain.gh example everything seems to work as expected:

However, if I change the latitude/longitude to say 64.00,00.00 , I get these errors:

Any ideas of what might be causing this? Looks like it might be a number of things.

(Also, if it is more appropriate to post Gismo issues elsewhere, I’d be happy to do so)

Best,

Anders


#2

Using the second source_ option appears to work:

Still though, it would be great to know why the first method fails (just educating myself here :slight_smile: )

/A


#3

When no “_source” is supplied the default SRTMGL1 source only gets terrain from -55 to 59 latitude.
Maybe the error you get is because you were giving a latitude of 64.


#4

That was exactly it, I simply didn’t manage to read the input params documentation close enough :man_facepalming:


#5

Hi @AndersDeleuran. I am glad the issue was solved by @jaco. Thank you Jaco!
I definitely admit that the component should simply stop working if SRTMGL1 has been chosen for the “_source” input, if location’s latitude exceeds supported mentioned latitude.

Anders, if you have any other issues, you can also open a topic on Gismo group.


#6

In the spirit of sinking ships/splintering userbases, perhaps adding a Gismo Grasshopper subcategory might also be appropriate :flight_arrival: