Gismo installation MapWinGis

Hi, I’m facing some issues with the installation from Gismo. Below are the errors shown from running the code attached. Appreciate any help. Thanks! (12.5 KB)

Hi @john.zapanta ,
Can you show what comes out of the Gismo_Gismo component’s readMe! output. Like this:

hi @djordje

Hi @john.zapanta ,
Thank you. And no Interop.MapWinGIS.dll file exists inside the c:/dev/MapWinGIS folder?
If that is so, then the MapWinGIS installation has not been successfull.
Can you uninstall your MapWinGIS version, download the x64 one. Once download of the file has been completed, check if the MapWinGIS-only-v4.9.6.1-x64.exe file is blocked.
If it is: unblock it (right clock on it → Properties, check 'Unblock box and select 'Ok'). Then right click on it -> choose 'Run as adminstrator and just press 'Next` until the completion of the installation.

Hello Djordje,

I followed all of these steps but I am still having the same issues that @john.zapanta was having where Gismo is not reading that MapWinGIS has been installed.

After I ran the file as administrator I am still finding that the Interop.MapWinGIS.dll file exists inside the c:/dev/MapWinGIS folder.

Any additional thoughts on how to get it to download properly so I can use Gismo?


Hi @Teegan ,
Can you follow these steps:

You also need to unblock the MapWinGIS.exe installation file, before running it.
Also, it may sound obvious, but Gismo does not work on Mac, only on Windows Rhino version.

Great! I don’t know what the difference was here (maybe the version or perhaps I wasn’t unblocking the .exe file before running it as administrator), but it worked.

Thanks for the help. I appreciate it.


1 Like

Hi @Teegan ,
In my humble opinion it is the unblocking of the downloaded MapWinGIS.exe that always needs to be done, otherwise installation can be somewhat faulty.

Glad that it worked.