Gismo: Problem Occuring, can't create buildings in 3d

This is the error:

  1. The component generated invalid shapes data.

To fix this issue, simply rerun the component (set the “_runIt” input to “False”, and then again to “True”).

Tried it, didn’t work - any tips?

Hi @mahmoud.ramdane ,
Can you attach you .gh file please? Thank you.

Here you go!

gismo vienna [May-17 '22, 1428].gh (160.8 KB)

Hi @mahmoud.ramdane ,
Thank you for the file.
Everything works fine on my PC. Check the screenshot below.
I am not sure why you get that warning. Try deleting the whole folder: C:\gismo\osm_files\Vienna_48.2077_16.3737_radius=1.0KM,
close Rhino, then run Rhino again, and run your .gh file again.

Hmm, weird, it still did not work.

I mean It used to work 4 days ago…

If you are using the model to just make a schematic preview of the urban area, then I wouldn’t be bothered with the message you get from Gismo.

Ikt, but I need the buildings with the heights which it doesn’t seem to display unfortunately.

Thanks for your Help @djordje !

Hi @mahmoud.ramdane ,
Which MapWinGIS version do you have installed?

I just installed fresh and got this result.

2 Likes

MapWinGIS 4.9.6.1

I’ll re-install guismo and check again.

Hi @mahmoud.ramdane ,
Don’t uninstall Gismo. You should try to uninstall MapWinGIS.
Try this:

  1. Close Grasshopper and Rhino
  2. Run the Revo Uninstaller Pro and uninstall your MapWinGIS application along with removing all the leftovers from the registry. Download 30 days PRO trial version of it from here. Here is a youtube example of a bit older Revo Uninstaller. But the important part is that is shows how registry leftovers are removed.
  3. Restart your PC, and once it boots again, make sure that you are logged in as an Adminstrator!
  4. Download the 64 bit version of v4.9.6.1 MapWinGIS.
  5. Right click on downloaded MapWinGIS-only-v4.9.6.1-x64.exe file, and choose “Properties”. If there is “Unblock” button click on it, and then click on “OK”. If there is no “Unblock” button, just click on “OK”.
  6. Left double click on MapWinGIS-only-v4.9.6.1-x64.exe file and install it to “C:\dev\MapWinGIS” folder. Choose “Full installation” during installation process! Basically to install MapWinGIS, just click Next until the end.
  7. Delete all files from the C:\gismo\osm_files folder
  8. Run your .gh file again.

Worked like charm, thanks djordje!