Ghosted View Shade Issue - 5A783w


#1

On a nMP 2013, with Ghosted view settings previously customized from default, I see the following anomaly that was not in the prior versions. Happened with one existing file as well as a newly created file with just a simple box element. I upgraded from 5A751 and have not used the versions between. Have not had a chance to test other Mac models.

Different from how Ghosted view has always work in past (the ghosting) The color is “washed out” or “faded” when a file is opened, placed in ghosted view, or deselected.

Open file

It should look like this

If I select the object I get this

But then if I deselect the object it will “fade”

And if I rotate or update the view, without selecting the object, it reverts to “normal.”

Unless something has changed affecting my prior settings I have not grasped? Here are those setting:



Software information

Software versions
Rhinoceros version: 5.0 WIP (5A783w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.3 (Build 14D131)

Plug-ins
None

Third party kernel extensions
com.paragon-software.kext.VDMounter (526.1)
org.virtualbox.kext.VBoxDrv (4.3.12)
org.virtualbox.kext.VBoxUSB (4.3.12)
org.virtualbox.kext.VBoxNetFlt (4.3.12)
org.virtualbox.kext.VBoxNetAdp (4.3.12)
com.paloaltonetworks.kext.pangpd (1.0.0)

Hardware information

Computer hardware
Hardware model: MacPro6,1
Processor: Intel Xeon CPU E5-1680 v2 @ 3.00GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD FirePro D500 3072 MB
Memory: 3072 MB
Screen size: 2560 x 1600
Displays: Cinema HD (101dpi 1x)

USB devices
SanDisk: Extreme
OWC: Elite mini USB3
LaCie: Rugged USB3-FW
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Cambridge Silicon Radio: MX1000 Mouse
Broadcom: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.32.20
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 0x
Mip map filtering: None
Anisotropic filtering: None

edited for typos…


#2

This description in this post kind of sounds like it might be the same thing if I’ve interpreted correctly, though perhaps not???


#3

i’ve noticed something sort of similar lately (as mentioned in the thread you linked to) in the display mode i generally use… (it’s a custom mode based on shaded except surface shading has a very low transparency set… around 3% iirc)… i’ll investigate later tonight to see if i can come up with any sort of relevant/helpful info on the issue.


edit- after a quick test on my laptop, i’m seeing the same ‘fading’ you’re showing in this thread using default ghosted display mode.

switch from shaded to ghosted:


select object:


deselect object:


tiny bit of zoom:


#4

Thanks for confirming this Jeff! I’m a sad dummy when it is “just me…” :sob:

Ghosted is my go-to. Kinda stuck on it. Found 5A783w rather undesirable in this state, especially when the model is more dense - fade/flash is rather annoying. Needed to get something done and went back to 5A751 for the time being.


#5

I was also able to replicate it, though i didn’t have the object engage in the “light” view until i clicked on the object a second time after selecting it:

This behaviour happened whether i had the Gumball active or not.


#6

i imagine this is all related but another symptom i’m having… dragging for a window select causes flickering…

[edit]… bummer, the youtube upload must of messed with the frames per second and isn’t showing exactly true… it’s actually a very fast pulsating flicker… seizure inducing :wink:

[edit2]
here’s a link to the non-youtubed version: (13MB)
https://dl.dropboxusercontent.com/u/16524160/ghostFlicker.mov

[edit3]
oh… neat… didn’t realize a .mov via dropbox will display inline like this


#7

Been having this issue for the last few builds, this is more related to flickering. The other issue seems to also involve PictureFrame.

I don’t use ghosted mode much, but get this in shaded.


(Dan Belcher) #8

@jeff, are you able to replicate this on your machine?


(Marlin Prowell) #9

I found the cause of this. It will be fixed in the next WIP release.


(Jeff Lasor) #10

@Dan, yes I think I’m seeing it here as well…or at least something similar. It’s quite odd that the same object is rendering differently in different passes. Unselecting the object, which causes an update to the drawing is (theoretically) no different than just drawing the object when panning, rotating, etc… and yet it draws differently.

I will try to look at this in more detail this week… It also seems like this might be similar a bug on my list, just described differently.


#11

as far as i can gather, this is fixed and ghosted/transparent surfaces are working well in 5A794w.
:ok_hand:


#12

I concur with Jeff; ghosted seems to be fixed in 5A794w.

Appreciate the speedy resolution.


#13

Sorry to dredge up an old thread, but I noticed the Ghost View was less-than-great in today’s modeling session.

Normally, I do ALL of my modeling with the computer in BootCamped Windows 7 running Rhino 5. There, everything works well.

This past week, I thought I’d hang around on the OSX side and model in Rhino for Mac.

In my usual Rhino sessions, I’ll occasionally toggle the screen to Ghosted mode to better understand a complex shape. This is when I realized I wasn’t getting the Ghosted mode I normally see in Windows Rhino – keeping in mind both programs are using the same underlying hardware (i7 Retina MacBook Pro). I haven’t mucked around in Rhino OSX’s graphics settings, so presumably it’s all at their defaults.

Apparently objects (polygons) that have flat faceted surfaces do appear ghosted as expected, but complex surfaces do not:

From Rhino OSX’s About section:

Software information

Software versions
Rhinoceros version: 5.3.1 (5D193)
IronPython version: 5.1.2015.131
Language: en-US (MacOS default)
macOS version: Version 10.12.3 (Build 16D32)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro10,1
Processor: Intel Core i7-3820QM CPU @ 2.70GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 1024 MB
Memory: 1024 MB
Screen size: 1680 x 1050
Displays: Color LCD (258dpi 2x)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Broadcom: Microsoft Sculpt Touch Mouse SDP Server , Microsoft Sculpt Touch Mouse , Microsoft Sculpt Touch Mouse PnP Server

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.14.20 355.10.05.15f03
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 0x
Mip map filtering: None
Anisotropic filtering: None


(John Brock) #14

Can you please send the file?
The icon I highlighted in yellow is the upload link:


#15

Here’s a variation that shows a polygon and cylinder tube object with expected ghosting displayed, but the swept surface is opaque.

GhostedBug.3dm (3.3 MB)

Changing layer colors has no effect in the behavior. Zooming in and shifting the view around might show the faintest signs of ghosting, but for the most part it’s a useless amount.


(John Brock) #16

I don’t understand it, but if I crank up the transparency setting in the Ghosted display mode (Rhinoceros > Preferences > Display Modes > Ghosted
to 75-80%, it looks much better.

I’ll check with @marlin and see if anything has changed recently regarding those settings.


#17

Thanks John
Was previously going into File > Settings and wasn’t seeing anything applicable. I’m sure I won’t be the only Rhino for Mac user who overlooks the separate Preferences and Settings areas.

Bumping the Transparency up beyond 70% lets me get back to modeling again.


#18

@CarterTG reminded me that other Ghost issues still exist across Mac models and through 5E12w.

There is a thread on that. Will move further info to this thread…


(Pascal Golay) #19

Capping the object makes it more transparent as well. Exploding the others makes them less transparent…

https://mcneel.myjetbrains.com/youtrack/issue/MR-3051

-Pascal