Ghosted, Doubled Screen

My screen gets blurry and doubled at least 40 times throughout the day. It was happening on my old computer and I thought it was because it was old, but I just got a new laptop and it’s still lagging like this. The only way to fix the problem is by resetting my viewports or closing and reopening Rhino (which is a waste of time. The screens usually behave like that when I double-click my current viewports to change from one viewport to four, or when I try to change the display modes (by clicking the dropdown of my selected view). My SystemInfo and Windows Display Dialog are all okay. I haven’t been able to find anything similar to this issue to help me. I’m unsure as to how I can solve this.

I’ve never seen anything like that before. Bizarre.
My initial guess is this is a symptom of something else going on with Windows or with display drivers.

Please post your SystemInfo anyway. It will give us a place to start.

Is this a Laptop or Desktop?
How many monitors are you running?

Thanks

Duplicate post. Doubled Screen - #10 by Marta_Halwany

Marta, You mentioned this happens on multiple machines, are these controlled via the office IT dept? This is very atypical and it would be good to know the system info and any ‘specialty’ software that have been loaded on each.

I would be inclined to reinstall your GPU drivers and use the “clean install” or a reset option to make sure you’re using default settings.

Another thing to try to see if it has any affect is in Options > View > OpenGL, move the OpenGL slider a click to the left, just to see what happens.

Hi Japhy,

No additional software has been installed on this computer (aside from Rhino and Autodesk). This machine happens to be the office one, but it’s happened on my personal laptop before as well.

Hi John,

Thank you! I will try out the OpenGL command and see if it works.

To be clear, we’re not looking for fixes here, just clues as to what might be happening, hopefully leading to a fix or work-around. If my guess that it’s related to OpenGL graphics or drivers, this is just poking at things we can poke at.

I changed the OpenGL one click to the left and it’s still doing it.

I do not see any of the “double screen” in that screenshot.

You can see it in the perspective tab

Each screenshot was within 5 minutes of each other

Our Display Development team has no idea how they could even make this happen. This is extremely atypical and very puzzling, more so that it happens on multiple computers for you, but this is our only report of the behavior.

It appears to only be affecting the Perspective in this screenshot, not the Right View below.

image

It’s happened before on my personal account, which is also confusing. It usually affects the viewport that I’m trying to click out of, and I work mostly on perspective.

There are some reports on Window 11, one recommends making sure your graphics acceleration is on.

https://answers.microsoft.com/en-us/surface/forum/all/surface-screeen-doube-image-double-vision-when/b135e939-9673-4ba1-9858-9307007b1794
https://answers.microsoft.com/en-us/windows/forum/all/help-double-vision-on-the-screen/4a17824c-fc3a-4747-93e4-10a999f41ba3

LCD monitor?

Great, thank you so much! I’ll try these out and hope that one of these work.

When you updated your Nvidia drivers, did you choose the Advanced button and check the “Clean install” option?

I bought the computer with Nvidia already downloaded and updated, I haven touched the default settings. I don’t know if there is anything you recommend that I should look for?

Yes.

  1. Run the latest Nvidia driver installer.
  2. Click on the “Advanced” button.
  3. Check the option for doing a “Clean install”.
    This will remove any custom, user settings and that can cause strange display problems.

Updating display drivers; like updating Windows and Rhino, will be general maintenance things you’ll need to do from time to time.

I can’t find an advanced option (under the sub-categories either) in the Nvidia control panel