GH Python error on first run (Rhino 6 Beta)

ghpython
unhandled

#1

I haven’t scripted anything yet and it’s throwing errors like this


(Pascal Golay) #2

Hi Will - does it run if you run EditPythonScript once beforehand?

-Pascal


#3

I ran the rhino native python editor and started ghpython again. It gave me the error again. By the way ghpython in my rhino 5 + GH runs normally.


Grasshopper python can't run
(Pascal Golay) #4

@DavidRutten - any idea what to check here?

-Pascal


(Marios Tsiliakos) #5

@Will_Wang,

Can you please check whether you have ironpython 2.7.3 installed. If yes uninstall it and try again

Cheers
M


Grasshopper python can't run
#6

I’m also using python node in Revit’s Dynamo, which seems to depend on the Ironpython I deleted. Do you happen to know if there is a way that I can python in both at the same time?


(Marios Tsiliakos) #7

@Will_Wang ohhh yes. I forgot to mention that this ironpython module comes with Dynamo.

As I recall the Rhino6 comes with ironpython 2.7.5. Hence the conflict. This is a Revit/Dynamo issue as it enables system wide software installation. As carefully documented by @AndersDeleuran here

To be honest I am not sure how you can workaround this.
¯_(ツ)_/¯


#8

A few things to try here: http://developer.rhino3d.com/guides/rhinopython/python-troubleshooting-install/


(Baker) #9

Just a question.
I was just wondering why Rhino6 has trouble with the system-wide IronPython that comes with Dynamo?
I mean isn’t the path to IPy 2.7.5 hardcoded? on C:\Program FIles\Rhino 6\Plug-ins\IronPython to be exact.

On a side note, I guess this would break the compatibility with Ladybug Tools and other plugins relying on Python right? (unless of course one uninstalls the Dynamo IPy lib.).
On another note, are there any issues on having both Rhino 5 and 6 installed on the same computer? (Given that they share the same Special folders, I think).


#10

I have no problem running rhino5 and 6 in parallel. Funny thing is rhino5 ghPython is not affected by the ironpython installed by Dynamo


#11

I don’t know if this is connected to others problems, but I installed RhinoGears and it did not work. I then tried to do as was told in the installation notes, I ran EditPythonScript in R6 and RhinoGears still didn’t exist. I tried a couple of times but still with no success. I then went to R5 and ran EditPythonScript and then RhinoGears was functioning in both R5 and R6.


(Marios Tsiliakos) #12

@Will_Wang

FYI if you haven’t already seen it.
http://dynamobim.org/dynamo-and-ironpython/

Cheers
M