Ghpythonlib not working in current WIP Rhino 6?

grasshopper
python

(Chris Hanley) #1

Testing out the current WIP for Rhino 6 and the getting my first look at the new grasshopper python component.

When importing ghpythonlib.components, (or just opening the sample for standard grasshopper functions), I get the following error:

  1. Solution exception:Method not found: ‘Void Microsoft.Scripting.Utils.ExceptionUtils.RemoveData(System.Exception, System.Object)’.
    (full error below)
    Runtime error (MissingMethodException): Method not found: ‘Void Microsoft.Scripting.Utils.ExceptionUtils.RemoveData(System.Exception, System.Object)’.

Traceback:
line 67, in , “C:\Program Files\Rhino WIP\Plug-ins\IronPython\Lib\types.py”
line 115, in __build_module, “C:\Users\chanley\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\lib\ghpythonlib\components.py”
line 150, in , “C:\Users\chanley\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\lib\ghpythonlib\components.py”
line 14, in script


Grasshopper python can't run
(Nathan 'jesterKing' Letwory) #2

@Alain, something for you?


GHPY plugins and IronPython installations
(Chris Hanley) #3

Anyone else run into this? (bump).


(Chris Hanley) #4

Updated to iron python 2.7.5, as well as most recent rhino WIP, (6.0.16117.17511, 04/26/2016) and it fixed this issue.


#5

I’ve just ran into the exact same issue and I have the latest Rhino WIP (downloaded today) as well as iron python 2.7.7 or later (it said the latest release on the iron python site was older than the currently installed). Did you have any more problems with this? Any other clues how to solve it?
Many thanks

Jakob


#6

Have you tried this? http://developer.rhino3d.com/guides/rhinopython/python-troubleshooting-install/


#7

@ MarcusStrube
Thanks, that made it!
I found an older Iron Python version (2.7.3), uninstalled it and now it seems to work as it should! I had completely forgot I installed it in the first place, so I didn’t look for it until now.


(Chris Hanley) #8

I made a discovery the other day regarding this issue. Like many of you, our shop uses a few “suites” of software products, which includes Autodesk suites. I think this particular error I was experiencing originally, is specific to Dynamo, but I might be wrong. While I’m not 100% sure which way this happens, (I believe it varies depending on the way in which you deploy/install the product), it seems that if you install a suite that includes Revit/Dynamo, it will install IronPython 2.7.3.
Some disucssion here:

I noticed this because I just installed Revit 2018. Some time after that, I opened Rhino 6 WIP and saw the error again. The solution was the same as noted earlier, to uninstall ironpython 2.7.3 from the windows control panel->Programs and Features.

I am certainly not requesting any assistance for a non McNeel product, just wanted to note that this was our experience. I will also note that this solution does break ironpython components in dynamo.


(Chris Hanley) #9

For anyone that runs into this issue, I have found a reasonable solution. This may apply to you if you use custom python components in dynamo and grasshopper. This solution works as of Revit 2018.1 and Rhino WIP (6.0.17269.9391, 9/26/2017).

Grasshopper IronPython version on our workstations is 2.7.5
-If your firm deploys AutoDesk Suites as “Custom Deployments” that include Revit/Dynamo, it seems that it will install IronPython 2.7.3. (this does not seem to be the case for individual users on subscription).
-Manually uninstall 2.7.3.
At this time, your Grasshopper Python component error will be resolved, but python components in Dynamo will break.

Manually install 2.7.4 (http://ironpython.net/)
_This seems to resolve the issue! I have not tested with any other versions, but as of now, this seems to be a stable solution.


IronPython installation + Rhino 5 / Rhino 6 / Rhino WIP
Grasshopper python can't run
Problem with GhPhyton Script
Grasshopper Python Error Message
#10

Yes me


#11

Thanks for the info.

Just had the same error with the RhinoGears plugin running in Rhino 6. Updating from IronPython 2.7.3 to the current version (2.7.8) solved the problem.