Geometry disappears whilst rotating and bounding boxes are drawn

Geometry disappears whilst rotating and bounding boxes are drawn using rotate command with the shaded view.

I’ve updated the graphics card, this behaviour does not happen when in rendered view, any ideas on how to stop this behaviour?

Hi @jaybee63
Two things: Does this happen even with simple scenes, eg. a couple of simple boxes or is it only with complicated scenes?
Also, run the SystemInfo command in Rhino and post the result here.
HTH, Jakob

Hi Jakob,

Yes, it happens with simple scenes, if I draw a sphere and have no other geometry I still get the bounding box when rotating in shaded view.

Here are the results from the systeminfo command
Rhino 7 SR27 2023-2-1 (Rhino 7, 7.27.23032.13001, Git hash:master @ 4a0030c0d354560df03764f4f49ecc5d119e5118)
License type: Commercial, build 2023-02-01
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2200 (NVidia) Memory: 5GB, Driver date: 12-22-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 528.02
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-22-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino
C:\Users\john\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Bullant\\bullant.rhp “bullant”
C:\Users\john\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi @jaybee63
First thing to check is that you don’t have BBox display enabled in the settings for your shaded view (marked in blue on the screengrab). Other than that, you could try to update your graphics card driver, although it’s quite recent.

HTH, Jakob

I’d 2nd what Jakob said, and also add that you may try disabling these plugins as a test to see if it has any effect-

Rhino plugins that do not ship with Rhino
C:\Users\john\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Bullant\\bullant.rhp “bullant”
C:\Users\john\AppData\Roaming\McNeel\Rhinoceros\packages\7.0*EleFront*\4.2.2\ElefrontProperties.rhp “ElefrontProperties”

Do you have three monitors hooked up to your graphics card? Maybe it’s not keeping up.

@Helvetosaur , I think you are right, I just noticed that… running 3 monitors they are underpowered by a good chunk… rhino needs 4gb vram per monitor and they only have 5gb vram total.

They are 7gb short on vram for your set up.

fwiw, video cards on ebay are cheap right now… Grab your self a used nvidia rtx card with 12gb and you’d be pretty happy-

heres some to check out-

Hi Jakob.
Thank you for the suggestion.
I have checked and bounding box is turned off.

Yes I have 3 monitors, but only one is used for Rhino, one perhaps for grasshopper and the other just to view photos of the project I’m working on.
There is no problem with any of the other viewport settings including rendered

Hi John -

But, as a test, does it change anything when you disconnect the two others?
Also, have you tried to see if the Rhino 8 WIP behaves in the same way?

Hi Jakob, i had checked the bounding box tick box relative to the wrong view (not shaded), just double-checked and you were right and the problem is now solved. Thank you so much

1 Like

I would like to say thankyou to " everyone" who has helped and replied.
This really is a great forum for support with a great product

Hi @jaybee63,

Glad you’re sorted. Please tick the Solution box on Jakob’s post so browsers see the issue is solved.