Force clean rendering with ambient occlusion on

Is there a way to force a cleaner, full-resolution rendering for the viewport modes with ambient occlusion turned on while moving the camera (zoom, pan, rotate, dolly zoom)? There is a very pixelated and noisy rough rendering of the scene while doing so via the RMB or a 3d mouse.
However, the rendering is perfectly smooth and sharp while using the mouse wheel to zoom in or out, or by pressing the left and right arrow keys to rotate the camera, which means that it’s technically possible to get rid of the temporary pixelated rendering (probably at the cost of a slower framerate).
Other CAD programs and video games using ambient occlusion don’t suffer from such low quality rendering.

hi Bobi,

there is some control over this via Advanced Options, keep in mind that this degradation is there by default to improve display speed however on good hardware all works quite well with no degradation.

Check out this thread:

Keep both @ 1 for no degradation.



1 Like

Hi Jarek, thank you for the tip! I can still notice some small amount of pixelation (temporary lack of anti-aliasing) even when I set the “SkylightShadow.ResolutionScale” option to 1 (default value was set to 2). The noise is still present, too. I guess that the denoiser is only active while the camera is fully static, otherwise it will not trigger during camera movement. Is there a way to force the denoiser 100% of the time?

Not sure why this topic have been moved to the “Rendering” section since it’s not related to rendering with the likes of Rhino Renderer, Cycles, V-Ray etc. :slight_smile: It’s about the bad resolution of the viewport modes that use ambient occlusion, as well as the noise that’s present during rotation of the camera while modeling.

Hi Bobi -
You mentioned the denoiser?
If this is a Raytraced viewport, it’s using Cycles…

It’s about a bad picture quality of the viewport during 3d modeling, not the typical rendering which is done via Cycles for making image files. :slight_smile:

Hi Bobi,

I assume you were talking about the Non-Cycles modes with Skylight shadows (OpenGL display), correct? In that case the above settings are the only ones I know of that are responsible for the AO shadow map quality (1=best quality, 2=1/2 map size downsampling, 3=1/4 map size downsampling). With the 1 set for Dynamic Display I don’t see any difference between static vport and dynamic, both with shadow quality and antialiasing, so I am not sure where your AA problem comest from.

BTW, the reason arrows and scrollwheel vport moves look OK is that they actually don’t kick in “Dynamic Display” degradation as they are kind of “one step” moves (even though scrollwheel may not feel like it).

With AO shadow quality, make sure to try maxing out Skylight shadow map quality slider in the display mode Shadow settings in the one you test with - since Rhino V7 Skylight shadows have their own slider independent of Cast Shadows slider. Maybe that would make a difference.

Lastly, there is a convoluted test command that controls more aspects of SSAO display, but other than intensity and radius that are quite helpful, I have no idea what other of these settings do:


Hi Jarek, that’s right, I was talking about the shadows in the viewport. As I mentioned above, when I set a value of 1 for the “Rhino.Options.OpenGL.SkylightShadow.ResolutionScaleDynamic” option, there is still some noticeable grainy noise and lack of anti-aliasing while moving the camera. On contrary, the “Rhino.Options.OpenGL.SkylightShadow.ResolutionScale” with the default value of 1 looks much better, with filtered noise and true anti-aliasing. However, if I opt to set a value of 2 for the latter, it looks equally aliased and noisy to “Rhino.Options.OpenGL.SkylightShadow.ResolutionScaleDynamic” set to 1. Unfortunately, it’s not possible to set a value of 0,5 for the latter, in order to reduce the aliasing and noise to the same level as the non-dynamic option.

I see the difference pretty easily on my screen, because it’s a large 4K 43" TV located about 80 centimeters away from my eyes. :slight_smile:

I use “Skylight shadow quality” set to 4, because 5, 6 and 7 look almost identical quality-wise /just tiny bit better) while reducing the framerate. Only the value of 8 makes a bit more difference, but it’s unusable with my video card. However, the problem is the low resolution of the geometry itself, because even a value of 1 for “Rhino.Options.OpenGL.SkylightShadow.ResolutionScaleDynamic” looks like using half of the screen resolution while moving the camera.

Along with the low resolution, the other big problem is that the shadow intensity changes suddenly while zooming in or out with a 3d mouse (SpacePilot), however, doing so by holding down the Ctrl key and the RMB while dragging the mouse results in a nice gradual change of the shadow intensity as the distance to the object changes. I think that this behaviour with the 3d mouse is a bug, because it’s not happening while zooming dynamically at perfectly smooth framerate the regular way via the keyboard and the mouse. I captured a video to show the issue by comparing both methods to zoom in or out.