Rhino Viewport Jittery when moving camera

as I move my camera in any viewport, my building or model begins to jitter as if it is dropping frames. I do not have any ram or CPU or GPU problems and I’ve never had this issue before. Could it be because of some bad geometry or some other issue?

Probably start with the _SystemInfo command and paste results here.

Rhino 7 SR29 2023-4-17 (Rhino 7, 7.29.23107.03001, Git hash:master @ 5f05ef3a2eea3d910c4c2fb79ccc75b413d33ca7)
License type: Educational, build 2023-04-17
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [88% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 7-11-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA RTX A3000 12GB Laptop GPU (NVidia) Memory: 12GB, Driver date: 5-30-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 529.08
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-30-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Users\kaami\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.23131.951
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Kamil - I would update to the most recent Rhino-


if that does not help, please try disabling Vray in Options > Plug-ins page, then close and re-open Rhino - is that better?


Both these solutions did not work.

Hi Kaamil - are the objects far from the world origin?


Hi, No they are not, Ive tried opening new rhino files as well where objects are on the origin but to no avail. It seems it’s definitely not an issue with the geometry or placement on the C plane. Could you recommend some other solutions. I updated as well and disabled Vray.


Okay, so when I move my rhino browser to another external monitor, the issue is gone. It seems that the rhino viewport only begins to “drop frames” and lags when on my laptops screen, do you know why this could be the case and what I could do to fix it. Is it possibly some kind of driver issue or something?

Can you change the DPI scaling to %100 in windows display settings?

Hi Kaamil - please make sure the NVidia control panel is set to use ‘high performance’ You can also change the setting for ‘vertical sync’ and see if that helps.


Hi, this seems to work but now everything on my laptop is quite small, the lag seems to occur on 125% dpi scaling. do you have any solutions?

I changed both settings and high performance was already on. This did not work. It seems to be a dpi scaling issue but is only happening with Rhino.

How about choosing 150% than 125%

This is a windows dilemma for the last decade.

That makes it worse. It does not happen on any other software

This did not happen on my laptop before. It has recently started occuring

Hello Kamal

Here are the steps that I suggest to do:

1- updated your RTX drivers to the latest, there is one release 2 weeks ago,
2- change your nvidia’s settings to match the below:

I did both things, no luck. Do you have any other ideas?


A silly suggestion here, but have you checked that Rhino is routing via your nvidia GPU and not your Intel iGPU. You may be able to check this by rotating the viewport with the Task Manager open (?) and then seeing which one is processing the OpenGL changes.

Alternatively, a blanket catchall may be to turn off “GPU Tesselation” in Rhino, to see if that fixes anything (especially if it is going through your Intel iGPU).

Hi Kaamil -

Do you know what has changed on your system in the meanwhile?

Hi, update to all, the latest Rhino update that came out today seems to have solved my problem. I was not able to figure out what the cause or solution was though. However I do not have the issue anymore.

1 Like