Fixing Rhino WIP Startup Faliures

tried one more time, uninstalled and did the “fix” and then reinstalled and still no luck.

WIP still thinks it is expired and also the toolbars are still gone.
Typing toolbar results in “Unknown command: _Toolbar”

in pluginmanager Toolbar is active and both Toolbar and ToolbarReset autocompletes, but neither is found.

This is embarrassing. We recently upgraded the web server that serves up the validation codes. The software running that server was out of date, and was handing out the same bad validation codes as the old server a few weeks ago.

So, the fix to this problem remains the same - please follow the steps at the very top of this thread once more - and Rhino should run properly.

Sorry for the hassle and the long time to get the resolution.

Still not working on my end. Tried the regedit from the top post and fresh latest build install.
Validation is successful but the WIP Expired/ no toolbars message is still here on the first run : (

I thought I got it working on my end but just checking now I get the multiple dialog boxes popping up and the installation rolling back. I now tried again but delete the registry key and LIC file and then tried installing from the latest msi. Now I got a Validation Failed message with a timeout error.

No luck.

  • Did the regedit

  • Deleted the .lic

  • Installed latest downloadable file

  • Started WIP and registered

  • Got the “WIP expired” dialog and still no toolbars…

PS! The download file is onlu 156 MB, but the download page says it is 560.6MB… is something missing?

Hi Holo,

I’d like to remote control your computer to see if I can figure out what’s going wrong… I’ll send you a private message to set that up.

I moved 8 posts to a new topic: Auto-Update install fails with RMA_CDKEY empty error

@brian Replying here because I have a manual install issue.
12-6-14: Ran, as an ordinary user, rhino_en-us_6.0.14337.13071.msi on my Rhino machine, which is not connected to the internet. It already had an expired R6 WIP on it.

Here’s what I got:

and this is what was installed:

I then uninstalled the WIP as a normal user and was asked for administrator account as expected.
I then logged off as normal user, logged on as administrator, and installed again.
When I ran it as administrator I got the same results as shown above for normal user.

Hope this helps.

Seems like you are making some changes to the process which are wrestling you pretty hard. Care to outline what’s changing?

Separate issue:
As part of trying to get a successful WIP install, I wanted to check that I had the latest build. To do this I went to your original starting post for Serengeti and followed the download link.

After giving my R5 license and email, I was forced to fill out (again) my name and address, etc., etc… What’s with this? Can’t this page recognize an e-mail it’s obtained before and skip the info request?

One clinker which may have derailed the normal process: I typed in my R5 license number first and forgot to fill in my e-mail info. The page rejected my submission and came back with the email entry highlighted in yellow. I filled it in, resubmitted, and then was routed to the lengthy info request.

Finally: I never would have needed to download the file if, in the area at the top of the download page, you included the full name of the file with the file date and size. To those of us with a rigorous mindset it seems possible that an update could appear on the same date as a previous WIP, so a comparison of filename (including the versioning info) would absolutely confirm whether it’s the same as already downloaded or not.

It is designed to only ask for registration information if the email address and key entered are not registered. I guess I’d need more details about what you put in for me to figure out what went wrong. Feel free to PM me your license key and email.

There are merely 11 different files you could have downloaded for each of the 11 languages we support. It is possible, but unwieldy, to list all this information on the first page of the download. I’m inclined not to do it, given how infrequently it would be useful to people.

Hello, when I start Rhino WIP I get this error message (see image). If I click continue I get to licence validation screen that does not work(nothing happens when I click next). Rhino WIP works just fine but it says it is beta version and in 38 days will stop saving my files. How can I validate my Rhino WIP licence? Thanks.

Thanks for reporting this. I hope to have it fixed in the next WIP. Usually we release WIPs on Tuesdays (which is today) but the build is currently not working very well, so we won’t have another until next week.


I just downloaded and installed the WIP for the first time and am having the same problem as VangelKukov and nscott. I guess I’ll check back next week.

Just to say that I am longer getting the same error after installing today’s update.

Excellent! Glad we managed to fix that one.

Yes, all fixed here too.