FindText command - does it work with dots?

According to the Help file, “The FindText command searches for specified text in selected text blocks, dimensions, leaders, and dots.”
When I run the command, it asks me to “select annotation” and will not allow selection of dots.

Hello - I see that, thanks.
RH-63047 FindText: dots are ignored


1 Like

After recent update (Version 7 SR6 - 7.6.21127.19001, 2021-05-07), when I run the FindText command (with hundreds of dots on screen) it reports: “This file contains no text objects. FindText can not run.” That is true, there are no text objects. I wish it could find text inside dots. :smiley:

I have 300 objects split into 9 pieces each (2700 total). Each piece needs a unique label. To save time I made a generic group of labels: 001A, 001B, … 001I, and copied them to give each object a set of these generic labels. Now, I need to go back and change 001 to whatever number it actually is, one at a time, per object. With FindText working I’d have 300 changes to make. Without FindText I have 2700 changes to make. It’s a lot of typing! :dizzy_face:

Just read the myjetbrains log. I might export the dot labels back to 6 and use FindText there, then back to 7. That’ll work. Wish I’d thought of it!

edit: ohhhhhh… Rhino 6 FindText command finds text. It does not replace text. :sob: Back to 7.

Hi -

That myjetbrains log says that the issue was fixed in Rhino 7.7. You can install Rhino 7.7 by changing your update frequency to “release candidates”.

Thanks for the hint Wim! I saw the note at the end of the myjetbrains log about 7.7 but assumed it was referring to a future stable 7.7 release, didn’t even occur to me that it was referring to the current release candidate! (a little knowledge is a dangerous thing, etc.)
Took me a minute to figure out how to re-enable McNeel update service. Using the advice in this post, I was able to turn on updates and access RC versions.
Downloaded, installed, tested… it works!!! I can find and replace text inside dots. Thanks everybody!